Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1 pixel wide graphical glitch down entire screen
#1
I'm pretty sure its the scaling causing this because this does not happen when playing in software mode or when using hardware native.

The problem I am having is during gameplay, the entire vertical row of pixels on the right are usually just garbled up random colors and garbage depending on whats on the screen.
This is on both the right and the bottom of the AMV's. I don't mind it on the AMV's as much, but during gameplay its very distracting an annoying.

I have attached screenshots.

   

   

I have spent maybe 5 hours trying tons of options to fix this and nothings working. The only thing I have not messed with is the EE/IOP, VUs, and GS settings. Direct3D11 or Direct3D9 were not a fix for this. I tried literally every individual hardware hack setting and many combinations of them. I tried AVX2, SSE4, and SSE2 2020 plugins, and none of those worked either.

I have only found one thing that helps so far. These temporarily for maybe 10 seconds or so go away if I leave fullscreen and go back into fullscreen. I can also switch to software mode and back with f9. It's not fixing it though, and it comes right back in mere seconds as I start to play the game again. Its too much of a hassle to keep pressing f9 twice every few seconds just to clear it off again.

Obviously I could just play the game at native, but it looks so terrible to me like that and I really want to be able to scale it. Is there anything I may not have thought of that you can think of to fix this?

I am using the newest version 1.6.0
Reply

Sponsored links

#2
(10-04-2020, 05:43 AM)DarkDream787 Wrote: I'm pretty sure its the scaling causing this because this does not happen when playing in software mode or when using hardware native.

The problem I am having is during gameplay, the entire vertical row of pixels on the right are usually just garbled up random colors and garbage depending on whats on the screen.
This is on both the right and the bottom of the AMV's. I don't mind it on the AMV's as much, but during gameplay its very distracting an annoying.

I have attached screenshots.





I have spent maybe 5 hours trying tons of options to fix this and nothings working. The only thing I have not messed with is the EE/IOP, VUs, and GS settings. Direct3D11 or Direct3D9 were not a fix for this. I tried literally every individual hardware hack setting and many combinations of them. I tried AVX2, SSE4, and SSE2 2020 plugins, and none of those worked either.

I have only found one thing that helps so far. These temporarily for maybe 10 seconds or so go away if I leave fullscreen and go back into fullscreen. I can also switch to software mode and back with f9. It's not fixing it though, and it comes right back in mere seconds as I start to play the game again. Its too much of a hassle to keep pressing f9 twice every few seconds just to clear it off again.

Obviously I could just play the game at native, but it looks so terrible to me like that and I really want to be able to scale it. Is there anything I may not have thought of that you can think of to fix this?

I am using the newest version 1.6.0

I think you should post your emulog.
Reply
#3
(10-04-2020, 06:46 AM)SeyedAli Wrote: I think you should post your emulog.


Code:
PCSX2 1.6.0-20200506140834- compiled on May  6 2020
Savestate version: 0x9a0e0000

Host Machine Init:
    Operating System =  Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
    Physical RAM     =  16208 MB
    CPU name         =  Intel(R) Core(TM) i7-5930K CPU @ 3.50GHz
    Vendor/Model     =  GenuineIntel (stepping 02)
    CPU speed        =  3.499 ghz (12 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7ffefbbf
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins from C:\Users\Aiden\Desktop\Emulators\Sony Playstation 2\Emulators\PCSX2 1.6.0\Plugins...
    Bound   GS: GSdx32-AVX2.dll [GSdx 20200506140834 (MSVC 19.25 AVX2/AVX2) 1.2.0]
    Bound  PAD: LilyPad.dll [LilyPad (20200506140834) 0.12.1]
    Bound SPU2: Spu2-X.dll [SPU2-X 20200506140834 2.0.0]
    Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20200506140834 0.11.0]
    Bound  USB: USBnull.dll [USBnull Driver 20200506140834 0.7.0]
    Bound   FW: FWnull.dll [FWnull Driver 20200506140834 0.7.0]
    Bound DEV9: DEV9null.dll [DEV9null Driver 20200506140834 0.5.0]
Plugins loaded successfully.

(GameDB) 9858 games on record (loaded in 196ms)
    (CdvdSource) HotSwapping CDVD source types from NoDisc to ISO.
HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: C:\Users\Aiden\Desktop\Emulators\Sony Playstation 2\Games\God Of War\God Of War.ISO
    Image type  = DVD
isoFile: second layer found at sector 0x001fbf30
* CDVD Disk Open: DVD, Double layer:
* * Track 1: Data (Mode 1) (4161520 sectors)
    Opening USB
    Opening FW
    Opening DEV9
3.x GL context successfully created
OpenGL information. GPU: GeForce GTX 970/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 419.35
INFO: GL_ARB_sparse_texture is NOT SUPPORTED
Override GL_ARB_sparse_texture detection (Enabled)
INFO: GL_ARB_sparse_texture2 is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_compute_shader is available
INFO: GL_ARB_shader_storage_buffer_object is available
INFO: GL_ARB_texture_view is available
INFO: GL_ARB_vertex_attrib_binding is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_multi_bind is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
INFO: GL_ARB_get_texture_sub_image is available
INFO sparse color texture is available
INFO sparse depth texture is available

Current Renderer: OpenGL (Hardware renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:0
McdSlot 0 [File]: C:\Users\Aiden\Desktop\Emulators\Sony Playstation 2\Emulators\PCSX2 1.6.0\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\Aiden\Desktop\Emulators\Sony Playstation 2\Emulators\PCSX2 1.6.0\memcards\Mcd002.ps2
GSdx Lookup CRC:0
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v02.00(14/06/2004)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
# Initialize memory (rev:3.70, ctm:196Mhz, cpuclk:147Mhz detected)

PlayStation 2 ======== Frame buffer size set to  512x512 (2560x2560)
Hard reset boot
ROMGEN=2004-0614, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
<20040614-100909,ROMconf,PS20200AC20040614.bin:11696>
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb  6 2003 08:38:48
  CPUID=2e20, BoardID=0, ROMGEN=2004-0614, 32M

Patches: No CRC found, using 00000000 instead.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_973.99;1) Game CRC = 0xD6385328, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname rom0:OSDSYS secname all
loadelf version 3.30
Input ELF format filename = rom0:OSDSYS
0 00100000 000586dc ......
Loaded, rom0:OSDSYS
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..
ROM directory not found

PlayStation 2 ======== Update reboot complete
cdvdman Init
rmreset start
rmreset end
clearspu: completed
Pad Driver for OSD (2000/12/05 18:05) 392, 128

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
read/write allocate memory 4000
open name rom0:OSDVER flag 1 data 4a978
open fd = 2
open name rom0:ROMVER flag 1 data 4a978
open fd = 2
open name rom0:XDEV9 flag 1 data 4a978
open fd = 2
loadmodule: fname rom0:XDEV9 args 0 arg
dev9: unknown dev9 hardware.
loadmodule: id 32, ret 1
loadmodule: fname rom0:XDEV9SERV args 0 arg
loadmodule: id -200, ret 1
open name rom0:FONTM flag 1 data 4a978
open fd = 2
open name rom0:FNTIMAGE flag 1 data 4a978
open fd = 2
open name rom0:SNDIMAGE flag 1 data 4a978
open fd = 2
open name rom0:TEXIMAGE flag 1 data 4a978
open fd = 2
open name rom0:ICOIMAGE flag 1 data 4a978
open fd = 2
open name rom0:TZLIST flag 1 data 4a978
open fd = 2
_spu_rev_offsetaddr 1f9021
### addr = 1034255  size = 28640
_spu_rev_offsetaddr 1d9021
### addr = 968719  size = 28640
open name rom0:ROMVER flag 1 data 4a978
open fd = 2
get val add 3c0 type 2 ret 1ff000
get val add 1ff000 type 2 ret 0
open name rom0:PS1ID flag 1 data 4a978
open fd = 2
open name rom0:PS1VERA flag 1 data 4a978
open fd = 2
open name rom1:DVDID flag 1 data 4a978
open fd = -6
(UpdateVSyncRate) Mode Changed to DVD NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
Frame buffer size set to  640x512 (3200x2560)
ExecutePs2GameDisk
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
open name cdrom0:¥SYSTEM.CNF;1 flag 4 data 4a978
open fd = 2
# Restart.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Restart Done.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname rom0:PS2LOGO secname all
loadelf version 3.30
Input ELF format filename = rom0:PS2LOGO
0 01000000 00019bf0 ..
Loaded, rom0:PS2LOGO
start address 0x1000008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
read/write allocate memory 4000
open name rom0:ROMVER flag 1 data 44078
open fd = 2
loadmodule: fname rom0:OSDSND args 0 arg
loadmodule: id 25, ret 0
_spu_rev_offsetaddr 1dfff1
### addr = 2097120  size = 32
_spu_rev_offsetaddr 1f9021
### addr = 1034255  size = 28640
(UpdateVSyncRate) Mode Changed to NTSC.
# Restart.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Restart Done.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SCUS_973.99;1 secname all
loadelf version 3.30
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
Input ELF format filename = cdrom0:¥SCUS_973.99;1
0 00100000 001c7018 .............................
Loaded, cdrom0:¥SCUS_973.99;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Elf entry point @ 0x00100008 about to get recompiled. Load patches first.
GSdx Lookup CRC:D6385328
GSdx Lookup CRC:D6385328
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥SIO2MAN.IRX;1 args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥DBCMAN.IRX;1 args 0 arg
loadmodule: id 26, ret 0
loadmodule: fname cdrom0:¥SIO2D.IRX;1 args 0 arg
loadmodule: id 27, ret 0
loadmodule: fname cdrom0:¥MC2_D.IRX;1 args 0 arg
loadmodule: id 28, ret 2
loadmodule: fname cdrom0:¥DS2U_D.IRX;1 args 0 arg
loadmodule: id 29, ret 0
loadmodule: fname cdrom0:¥LIBSD.IRX;1 args 0 arg
loadmodule: id 30, ret 0
loadmodule: fname cdrom0:¥989NOMID.IRX;1 args 16 arg rpc_priority=64

==========================================================
989snd (c)2000-2003 Sony Computer Entertainment America
by Buzz Burrowes                               v3.1.7
                        (built Dec 21 2004 at 14:30:44)
                                         (pre-release 12)

NO MIDI VERSION! No MIDI, AME, or basic VAG sounds
                  (banks and streams only)

(build with sce library rev 3.0.1)
==========================================================
    Thread Priorities:
                         Sound Tick = 9
                           Main RPC = 64
                        Loading RPC = 65
                          Streaming = 60, 61, 62, 63
==========================================================

loadmodule: id 31, ret 0
loadmodule: fname cdrom0:¥SMPD_IOP.IRX;1 args 0 arg
loadmodule: id 32, ret 0
============================
gCollectorLatch    = 12b2235
gDECISemaphore     = aaf91f
gStreamerSemaphore = aaf221
gDiscReadSemaphore = 12b5a31
gReadLatch         = 12b682d
gWriteLatch        = 12b612f
gSynchReadLatch    = 12b3733
============================
gReadThread        = 12b4c3d
gWriteThread       = 12b3e3f
gCollectorThread   = 12b2941
============================
Suspending single plugin: GS
    Saving GS
    Closing GS
Delete 0 Shaders, 136 Programs, 28 Pipelines
Recovering single plugin: GS
    Opening GS
3.x GL context successfully created
Override GL_ARB_sparse_texture detection (Enabled)
Current Renderer: OpenGL (Software renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:D6385328
    Loading GS
Suspending single plugin: GS
    Saving GS
    Closing GS
Delete 0 Shaders, 34 Programs, 28 Pipelines
Recovering single plugin: GS
    Opening GS
3.x GL context successfully created
Override GL_ARB_sparse_texture detection (Enabled)
Current Renderer: OpenGL (Hardware renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:D6385328
GSdx Lookup CRC:D6385328
    Loading GS
Frame buffer size set to  512x512 (2560x2560)
Suspending single plugin: GS
    Saving GS
    Closing GS
Delete 0 Shaders, 54 Programs, 28 Pipelines
Recovering single plugin: GS
    Opening GS
3.x GL context successfully created
Override GL_ARB_sparse_texture detection (Enabled)
Current Renderer: OpenGL (Software renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:D6385328
    Loading GS
Suspending single plugin: GS
    Saving GS
    Closing GS
Delete 0 Shaders, 34 Programs, 28 Pipelines
Recovering single plugin: GS
    Opening GS
3.x GL context successfully created
Override GL_ARB_sparse_texture detection (Enabled)
Current Renderer: OpenGL (Hardware renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:D6385328
GSdx Lookup CRC:D6385328
    Loading GS
Frame buffer size set to  512x512 (2560x2560)
Suspending single plugin: GS
    Saving GS
    Closing GS
Delete 0 Shaders, 75 Programs, 28 Pipelines
Recovering single plugin: GS
    Opening GS
3.x GL context successfully created
Override GL_ARB_sparse_texture detection (Enabled)
Current Renderer: OpenGL (Hardware renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CR    LoadingC:D63 GS
85328
GSdx Lookup CRC:D6385328
Frame buffer size set to  512x512 (2560x2560)
Suspending single plugin: GS
    Saving GS
    Closing GS
Delete 0 Shaders, 77 Programs, 28 Pipelines
Recovering single plugin: GS
    Opening GS
3.x GL context successfully created
Override GL_ARB_sparse_texture detection (Enabled)
Current Renderer: OpenGL (Hardware renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:D6385328
GSdx Lookup CRC:D6385328
    Loading GS
Frame buffer size set to  512x512 (2560x2560)
Suspending single plugin: GS
    Saving GS
    Closing GS
Delete 0 Shaders, 85 Programs, 28 Pipelines
Recovering single plugin: GS
    Opening GS
3.x GL context successfully created
Override GL_ARB_sparse_texture detection (Enabled)
Current Renderer: OpenGL (Hardware renderer)
    Loading GS
Reply
#4
I believe I have found the solution. I went to go play the game again today and I noticed the issue was not present anymore. The second I opened up and changed any setting in video, regardless of what the change was, this issue came back. Even if I didn't change any setting at all, and just opened and closed the video plugin configuration, the issue came back because it seems to refresh the plugin, or emulator upon closing, even if no changes are made.

I exited out of pcsx2 completely, and restarted the emulator up. The game proceeded to play without the issue again until I made any other change to the video settings.

It seems as long as I have the settings put in before running the game, and then do not change any setting in the emulator at all after the game is loaded, it appears to play just fine.
Reply




Users browsing this thread: 1 Guest(s)