3rd party PS3 controller not usable?
I'm a bit flummoxed here. I have here a 'Pro Ex' controller that I'm trying to get to work with the emulator, but I can't seem to get it to do anything. This is for Windows 7 64bit. Let me lay out what I've noticed:

In Motioninjoy, the dropdown simply says 'Waiting for controller to be connected...'

In Better DS3, it lists no connected controllers. However, when I open it's control panel, it lists the 'Pro Ex' under 'Installed Controllers'. Furthermore, when I do a device test, every button and analogs are working perfectly. It's just... not listed? It's detected, working, and tested successfully, but for some reason I can't use it.

Also with the PCSX2 program opened and an iso running (dark cloud 2 in this case, intending to run it for .hack G.U.) I go to config -> Controllers -> Plugin Settings and in the box at the bottom left, Device Diagnostics, it has 'DX Pro Ex' listed. Again, when I selected 'test device', every button works perfectly, but I still cannot figure out how to get the emulator to accept the controller input. Am I doing something wrong? Am I missing something?

Subnote: Also with the emulator running, I can't seem to get any keyboard input to do anything in the emulation either. Not too terribly important, but if I simply cannot get the controller to work, I'd like to at least have the option to use my keyboard to see if I can do that or if it drives me bonkers.

Edit: On the Motioninjoy, it's simply not detecting any controller. I also tried the alternative method to accept the driver for the controller by doing this:

I have an installed 'PS x64' folder, the driver. Plug in controller, open 'Devices and Printers', and double-click the controller. I go to the Hardware tab, double-click USB Input Device, and select 'Change settings'. From that window, I again go to the drivers tab and select 'Update Driver'. I use the 'Browse my computer' prompt and select the 'PS x64', and get the error message 'Windows has determined the driver software for your device is up to date.' I read somewhere that changing the date to 2014 resolves this - however, I still receive the same error. 

Any assistance with getting this resolved would be greatly appreciated. I used to run games on emulators, and now that my PS3 is having overheating problems, I'd like to run them on my PC so I can play without being constantly interrupted every hour to let it cool down.

Sponsored links

Got an update here, and a rather curious one... I plugged in a default/original PS3 controller (The one included with the machine), and after re-installing Motioninjoy, it actually detected the controller. I was able to successfully select the 'Driver Manager', checkbox the driver, and select 'Load driver'. After some fiddling and many sounds of USBs disconnecting and reconnecting, and re-started the PCSX2, I was able to access the Config again, re-map the controller, and get in-game. And... miracle, it actually works. I don't know yet if it works for my other modified controller that I actually want to use over this one. But... if at least this stock controller works, hell, that's good enough for me.

I'd still appreciate any instruction or feedback about the third party controller, but I'm just glad the stock controller is working.

Users browsing this thread: 1 Guest(s)