Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
40 FPS Cap on HDMI TV Fullscreen OpenGL
#1
For the past week or so, I've been trying to troubleshoot a strange issue with my laptop.

To start: at first, a couple weeks ago, all graphics modes, both hardware and software, were capped at 40 FPS whilst only on fullscreen (windowed bordered of any size runs at a consistent 100% speed, to this day). It affected not only PCSX2, though every other game on my laptop, as well. I managed to track down the cause of this particular issue, however, as I had downloaded a couple of recommended HP programs from HP Support Assistant, and the problem had started around the time I downloaded them. After uninstalling them, the FPS cap was removed - sort of.

I can't quite recall if the cap was removed from OpenGL at that time, though what matters is that the cap still exists/is back and it is now only affecting OpenGL mode, both in hardware and software. I can't say if it's only PCSX2 exclusive, as I've failed to find any other games that run off of OpenGL, so I cannot currently test this. Anyway, shortly after I realised this problem, I made a new discovery. I always play PCSX2 on my TV via HDMI cable, as it's a far superior experience. Upon removing the HDMI cable and checking my laptop screen, the FPS cap is removed and the speed returns to 100%, though as soon as I plug it back into my TV, it goes back down to 40 FPS (meaning slow motion gameplay, pretty much). I have tried plugging it into a second TV and the problem persisted, so I doubt that it is the fault of the TV.

I've searched for hours but have found no solution to this mind boggling issue. My games run perfectly fine on DX11 mode so it is definitely centred around OpenGL. Whilst I would simply play on DX11 at all times, a good majority of my games have severe issues that are only resolved when playing on OpenGL, so it's basically a must.

Without further ado, here are the specs of my laptop:

Model: Omen by HP (1DF05PA#ABG)
GPU: GTX 1050 4GB (laptop exclusive card)
CPU: Intel Core i7-7700HQ @ 2.80GHz (laptop exclusive chip, I'm pretty sure)
RAM: 8GB

If there is any further information I can provide then please let me know. Other than risking the removal of every piece of HP software on the system (I doubt it is the issue as I've had pretty much all of it since the purchase of my laptop), I'm out of ideas. I've even reinstalled the video drivers for my Intel and Nvidia GPUs to no improvement. Please help!
Reply

Sponsored links

#2
Check the refresh rate on your TV in your display settings. I don't suppose it's 40 Hz right now, and can be set to 60 Hz?
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#3
Star 
Lo and behold, barely ten minutes after posting this thread, I found the solution to my problem. In case there are any other people out there with a similar problem, I'll explain, step by step, how to replicate what I did.

1. Click the little Cortana button to the very right of the Windows button in the bottom left corner of your screen (if Cortana is disabled I'm pretty sure it just shows as a magnifying glass).
2. Type in "Display". A option titled "Change display settings" should be among the first of results to come up. Click on that.
3. Once the display settings window opens, scroll further down the settings until you see a title that says "Multiple displays".
4. Click the first drop down box below and select either "Extend these displays" or "Show only on 2". The first will project the image to both your computer screen and the TV at the same time, though unlike "Duplicate these displays" it did not have the FPS cap. The latter option causes the image to show exclusively on your TV screen and not your computer screen, and also fixes the FPS issue. For me, personally, the first option caused only my desktop wallpaper to show on my TV, along with the taskbar and nothing else, so I settled with the latter option.

Keep in mind that this solution is only achievable if you have some form of secondary monitor plugged into your computer, such as a TV, as I have. If you do not, the drop down box will not even appear. I hope that this helps another person in need.
Reply
#4
interesting. so... cloning is working? and extended slows down the secondary? that's like back in the old days sort of crap. and 'switching' the tv to primary fixes it to run on the tv? okay. maybe you could still use both with the tv as primary and the laptop screen as secondary. i'm not sure how fast the refresh on your laptop screen is then tho.

your optimus may have trouble to puzzle and pass your nvidia output into extended mode on this secondary hdmi. per default the intel alone on the hdmi should work flawless. it's basicly 'designed' as direct tv out. usually for really just tv decoding and secondary display stuff.

that 40 fps seem stupid tho. 1/40 are 25 ms refresh delay? microsh*t anniversary patch? still all old bad code. Laugh
Reply




Users browsing this thread: 1 Guest(s)