Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
60FPS Issues in KH2FM (Eng. Patch)
#1
Tongue 
I'm attempting to run KH2FM on v1.4.0 while using this cheat to adjust the internal FPS:

// 60 FPS Kingdom Hearts 2 Final Mix
patch=1,EE,00349E1C,extended,00000000

I'm convinced my hardware is more than capable of handling the strain, and yet I run into frequent FPS drops whenever a graphical load of any sort occurs (E.G. looking at a large background structure or certain skyboxes, a group of enemies spawning, etc.)

I'm not sure if there's a setting or speedhack I'm using that might cause these issues. Stranger still, I attempted a complete wipe of all settings and ran the game completely vanilla - aside from the 60FPS cheat, and I can't even come close to 60fps unless I'm running speedhacks.

EDIT: I might also add that the FPS drops occur in the same areas to the same degree even if I run the game on native resolution with zero shaders and anti-aliasing.

Maybe it IS just my hardware not being strong enough. If anyone can tell me for sure, I'd appreciate it.

Thanks! I'll post my rig and settings below.

OS: Windows 7 Home Premium
Processor: AMD FX-8350 8-Core 4.00 gHz
RAM: Ripjaws 16GB
Graphics: NVIDIA GeForce GTX1060 6GB
HDD: Seagate ST2000DM 1.5TB
SSD: Samsung SSD 850 EVO 250GB

                       

HW Hacks: Alpha, Half-Pixel Offset, Alpha Stencil
Reply

Sponsored links

#2
Download the latest dev build here and see if it resolves your issue: https://buildbot.orphis.net/pcsx2/

Also, you should use OpenGL since you own an Nvidia GPU.
Reply
#3
Also set the speedhack sliders back to default, you don't need them adjusted like that for this game, you're just upping the system requirements you need to run it
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
Can you run the game without the patch with your setting at always above 120fps?
There is no need to increase the EE speed because you are making it even harder to get constant 60fps(120fps)
Reply
#5
Appreciate the info, but no dice - the game's perfectly willing to run 60 FPS so long as there's no other entities on the screen.
It slows down proportionately to the amount of 'stuff' I'm looking at, no matter what resolution I run the game at.

I'm not sure what it is I need to do.
Do you want screenshots of my new settings with the build?

EDIT: Yeah, I've turned all the speedhacks off. Same situation - 60 FPS depending on whatever's on screen.
Reply
#6
You did not answer my question...the game is not all that GPU intensive but using the fps patch along with the EE speed hack,it increases the CPU requirements to more than twice
Reply
#7
Yeah, around 3x native I can zip around twilight town at 120fps with no stutters anywhere.

EDIT: Sorry, should've specified - I can set the base FPS to 200% (basically double the ingame speed) and get zero issues anywhere. The trouble comes when I enable the patch and run the game normally.
Reply
#8
You shouldn't have turned all the speed hacks off, just the sliders. You defo want the mtvu speed hack on
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)