A really weird FMV issue
So I've been testing a few games in PCSX2 and I've come across a strange issue with FMVs that I'd love to be able to fix.

The initial problem is that FMVs in Final Fantasy XII stutter/hitch for me every few seconds (PCSX2 1.0.0). I also get FMV slowdowns in Katamari Damacy and We Love Katamari in the few post-mpeg fix SVN builds I tried.

Now here's the strange part:
If I watch an FMV I've already suffered through a second time, then there's no hitching/slowdown and it plays perfectly. It doesn't matter if I do a soft-reset or completely close PCSX2 and reopen it again, that FMV will play perfectly fine as long as it has played through once. I can even change ISOs, load up another game for a while, then come back to the original game and it'll still be fine. However the hitching/slowdown will return once I restart my PC, until the FMV runs through again, and so on.

Now it gets even stranger:
If I interrupt a FMV (on the first watch through) at any spot before it's finished by resetting or closing PCSX2, then reload that FMV, there will be no hitching/slowdown for the part that already played the first time, BUT the hitching/slowdown will start again from around the spot I interrupted the FMV the first time (i.e. the bit that didn't play the first time).

I've tried a myriad of things to stop the hitching/slowdown the first time through, such as disabling/enabling all speed hacks, ending every single unessential process in the task manager, trying every graphic setting I can think of (it happens in DX9 and DX11, both hardware and software mode), switching to DirectSound rather than XAudio, messing with my graphics card drivers, messing with Windows power settings - none of those things make a difference.

The only thing I can think of that could cause this sort of behavior is something related to caching (at the disk level maybe? I have no clue). I have 2 hard disks in my PC, one is a WD Velociraptor and the other is a standard Samsung drive (before they were bought out by Seagate). If I put a copy of the same ISO on each drive, the issue will occur on both, and each will have the issue independently of the other (i.e. running through a stuttering FMV partially or fully in one will not affect the other in any way, no matter how many times I switch back and forth between them).

So yeah I'm really at a bit of a loss here, I'm gonna try setting my BIOS to IDE mode instead of AHCI now and see if that will do anything.

PC stats:
Intel Core 2 Quad Q9400
ATI HD6850 graphics

Sponsored links

So I feel really stupid now for typing up that massive post, but switching my disks to IDE instead of AHCI in my computer's BIOS seems to have fixed the problem. I was lead to believe that AHCI would offer superior disk performance because of NCQ or whatever, but apparently not in this case (I had the latest storage drivers installed and everything). Disks are running off an Intel ICH10 chipset for anyone interested, SATA obviously.

So this thread can be closed or whatever, but I guess it serves as a warning to others that PCSX2 issues could in fact be hard disk related.

Users browsing this thread: 1 Guest(s)