A strange speed up issue (NO turbo)
#1
Hello, everyone.

This is my first post and I'm new here, so... Please don't be too hard on me, if I accidentally broke some rule.
Just for the record, I DID gloss over the general rules before posting. Hopefully, I should be fine.

Recently, I've been having a strange speed-up issue(possibly with a false FPS reading too) on NORMAL mode. WITHOUT
 hitting "turbo".

Whenever I start up PCSX2, even without games, the frame rate goes up to around 62.5-62.8 FPS(most often, an odd number, like 62.77), with the speed reading from 105 to 125%. Again, on NORMAL mode, NOT "turbo". On top of that, I am also experiencing EXTREME button lag/unresponsiveness, to the point of unplayability.

The problem persists even after deleting and then re-installing PCSX2 multiple times.
The version I've been using, since day one, has been PCSX2 1.4.0. Always playing with the keyboard of my laptop.

What could be the problem?
Reply

Sponsored links

#2
Here are my laptop specs, in case anyone wants to ask:
OS Name Microsoft Windows 10 Pro
Version 10.0.17763 Build 17763

System Manufacturer Hewlett-Packard
System Model HP ProBook 450 G2
System Type x64-based PC
System SKU J4S96EA#AKD
Processor Intel® Core™ i7-4510U CPU @ 2.00GHz, 2601 Mhz, 2 Core(s), 4 Logical Processor(s)
Video card chip: AMD Radeon R5 2GB
BIOS Version/Date Hewlett-Packard M74 Ver. 01.42, 26-Sep-16
SMBIOS Version 2.7
Embedded Controller Version 103.37
BIOS Mode Legacy
BaseBoard Manufacturer Hewlett-Packard
BaseBoard Product 2248
BaseBoard Version KBC Version 67.25

Any meaningful advice is appreciated.
Thanks in advance.
Reply
#3
1) Are you sure, what you made really clean uninstallation of PCSX2? Maybe you didn't delete some files with configurations.

2) Can you make a screenshot of the "GS" and "GS Window" menus? It's placed in Config -> Emulation Settings -> GS and Config -> Emulation Settings -> GS Window.

3) Perhaps the problem is due to the drivers of the video card. Have you updated them recently? And you changed the vertical sync settings directly in the control panel of the video card?

4) Why you didn't try one of 1.5.0 development builds?
Reply
#4
(12-02-2019, 03:12 AM)ANd93ml Wrote: 1) Are you sure, what you made really clean uninstallation of PCSX2? Maybe you didn't delete some files with configurations.

2) Can you make a screenshot of the "GS" and "GS Window" menus? It's placed in Config -> Emulation Settings -> GS and Config -> Emulation Settings -> GS Window.

3) Perhaps the problem is due to the drivers of the video card. Have you updated them recently? And you changed the vertical sync settings directly in the control panel of the video card?

4) Why you didn't try one of 1.5.0 development builds?

I think, I didn't delete some config files, because I always had the option of importing configurations. Overwriting them didn't help.
I have also tried the 1.5.0 version. Didn't help matters either.
As for question No.3... I never thought of that. Maybe it could have smth to do with it.


Attached Files
.png   pcsx2_CoreSettings_GS Window.png (Size: 36,86 KB / Downloads: 173)
.png   pcsx2_CoreSettings_GS.png (Size: 53,32 KB / Downloads: 162)
Reply
#5
1) Why screenshots looks such broken? With white background for inscription, 16-bit palette etc?

2) You showing your actual settings? Have you tried to disable preset and then disable all speedhacks and game fixes?

3) Have you tried installing previous version drivers of the video card? And disable all kind of vertical synchronization in control panel of video card? Or you need manual for that?
Reply
#6
(12-02-2019, 05:43 AM)ANd93ml Wrote: 1) Why screenshots looks such broken? With white background for inscription, 16-bit palette etc?

2) You showing your actual settings? Have you tried to disable preset and then disable all speedhacks and game fixes?

3) Have you tried installing previous version drivers of the video card? And disable all kind of vertical synchronization in control panel of video card? Or you need manual for that?

1. Because pcsx2 saves snapshots like that.
2. Yes, these are my current settings. I may sometimes turn the preset off and change some settings for specific games, like Shinobido: Way Of The Ninja, but that's mostly it.
3. I don't think I can turn off vsync. I've heard, that it's impossible to turn it off for Windows 8, 8.1, or 10. But, if I'm wrong, do, please, elaborate on how to do it.

And yes, the speed-up issue happens even with the Safe preset.
Reply
#7
1) Well, disabling vertical synchronization in Windows 10 is a lottery. Usual way is to update the OS to the maximum and disable all optimizations for games. Perhaps it will help. Another way is downgrade to version where is everything work.

2) You turned off all vertical synchronization options in the control panel of the video card? In your case (AMD), this panel can be opened by right-clicking on the desktop and choosing in the drop-down menu "AMD Radeon Settings" or something like that.

3) Have you tried turning on v-sync exactly in emulator settings? This option is "Wait for Vsync on refresh". And you play in fullscreen mode?

4) What API do you use in the emulator? OpenGL or Direct3D?
Reply
#8
(12-03-2019, 02:50 AM)ANd93ml Wrote: 1) Well, disabling vertical synchronization in Windows 10 is a lottery. Usual way is to update the OS to the maximum and disable all optimizations for games. Perhaps it will help. Another way is downgrade to version where is everything work.

2) You turned off all vertical synchronization options in the control panel of the video card? In your case (AMD), this panel can be opened by right-clicking on the desktop and choosing in the drop-down menu "AMD Radeon Settings" or something like that.

3) Have you tried turning on v-sync exactly in emulator settings? This option is "Wait for Vsync on refresh". And you play in fullscreen mode?

4) What API do you use in the emulator? OpenGL or Direct3D?

1. Well, that's always an option, I guess.
2. Yeah, it's off. The problem still persists.
3. It's been unchecked and grayed out the whole time. And I play in maximized window mode.
4. I use Direct3D11, Hardware mode.
Reply
#9
Select the "Safest" preset, then uncheck the "Presets" box. "Wait for..." should be clickable after that. Also enable default fullscreen mode. And try to run something.

In addition, there is an option - run in fullscreen mode without synchronization. Try this one too.

And one more thing - force the maximum FPS of the emulator to 60. For that edit PCSX2_vm.ini file in way "emulator directory -> inis" by replacing parameters of "FramerateNTSC" and "FrameratePAL" lines on the 60.00

If it doesn’t help (or if you already tried it and it didn’t help) - then I just don’t know what to do.

Unless to use a system recovery point. Or reinstall/install previous vertion of videocard's drivers.
Reply
#10
(12-03-2019, 05:14 AM)ANd93ml Wrote: Select the "Safest" preset, then uncheck the "Presets" box. "Wait for..." should be clickable after that. Also enable default fullscreen mode. And try to run something.

In addition, there is an option - run in fullscreen mode without synchronization. Try this one too.

And one more thing - force the maximum FPS of the emulator to 60. For that edit PCSX2_vm.ini file in way "emulator directory -> inis" by replacing parameters of "FramerateNTSC" and "FrameratePAL" lines on the 60.00

If it doesn’t help (or if you already tried it and it didn’t help) - then I just don’t know what to do.

Unless to use a system recovery point. Or reinstall/install previous vertion of videocard's drivers.

I restored my system to a previous point. It worked. Thanks for the idea.
Reply




Users browsing this thread: 1 Guest(s)