AMD Single Core & ATI - Will It Work? - So Far No Go...
Well I've tried all I know, compiled this from svn on my box and all it does is either complain about MTGS if I run GSdx or seg faults with ZZ ogl.

I run Slackware 13.37 x86 with a AMD single core and ATI HD3200. I know on a single core it's suppose to have less performance and I know Nvidia is suppose to work better, but will this still work on a single core AMD with a ATI gpu?

Here's the output using GSdx;

/tmp/das/pcsx2-0.9.9_r4983/common/src/Utilities/Linux/LnxHostSys.cpp(63) : assertion failed:
    Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
    Thread:    MTGS
    Condition: false
    Message:   Unhandled page fault @ 0x00000008

[00] 0x0xb0629901                                
[01] 0x0xb062f34a                                
[02] SDL_CreateRenderer                          
[03] GSDeviceSDL::Reset(int, int)                
[04] GSDeviceSW::Create(GSWnd*)                  
[05] GSRenderer::CreateDevice(GSDevice*)        
[06] 0x0xb059c526                                
[07] GSopen2                                    
[08] 0x0x8086ac2                                
[09] 0x0x8086c7d                                
[10] 0x0x821e4ad

Here's the output with ZZ ogl;

das@box:~/Game/pcsx2-0.9.9_r4983$ ./pcsx2
Interface is initializing.  Entering Pcsx2App::OnInit!
Applying operating system default language...
Command line parsing...
Command line parsed!
(UserMode) Found portable install ini @ /home/das/Game/pcsx2-0.9.9_r4983/portable.ini
ZZogl-PG: Calling GSinit.
ZZogl-PG: GSinit finished.
ZZogl-PG: Calling GSopen2.
ZZogl-PG: Capturing ZZOgl window.
ZZogl-PG:  Got Doublebuffered Visual!
ZZogl-PG:  glX-Version 1.4 with Direct Rendering
Segmentation fault

Here's the Log at startup;

PCSX2 0.9.9.r4983  - compiled on Dec  9 2011
Savestate version: 0x9a060000

Host Machine Init:
    Operating System =  Linux 3.1.4 i686
    Physical RAM     =  3531 MB
    CPU name         =  AMD Athlon(tm) Processor TF-20
    Vendor/Model     =  AuthenticAMD (stepping 02)
    CPU speed        =  1.596 ghz (1 logical thread)
    x86PType         =  Standard OEM
    x86Flags         =  078bfbff 00002001
    x86EFlags        =  ebd3fbff

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3
    MMX2  .. 3DNOW .. 3DNOW2

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...

Loading plugins...
    Binding GS    : /home/das/Game/pcsx2-0.9.9_r4983/plugins/
    Binding PAD    : /home/das/Game/pcsx2-0.9.9_r4983/plugins/
    Binding SPU2    : /home/das/Game/pcsx2-0.9.9_r4983/plugins/
    Binding CDVD    : /home/das/Game/pcsx2-0.9.9_r4983/plugins/
    Binding USB    : /home/das/Game/pcsx2-0.9.9_r4983/plugins/
    Binding FW    : /home/das/Game/pcsx2-0.9.9_r4983/plugins/
    Binding DEV9    : /home/das/Game/pcsx2-0.9.9_r4983/plugins/
Plugins loaded successfully.

(GameDB) 9535 games on record (loaded in 817ms)


Sponsored links

One thing is for sure, that CPU and the clock speed DOES NOT MEET the minimum requirements for the emulator AT ALL.

As for the GPU, well according to the specification requirements, it meets the requirements, BUT like I said, the major issue is the CPU.
Actually from what I read it does;


Windows XP Service Pack 2/Windows Vista or Linux 32bit/64bit
CPU that supports SSE2 (Intel Pentium 4 or AMD Athlon 64 or faster)
GPU that supports Pixel Shader 2.0 (NVIDIA GeForce FX series or ATi Radeon R300 series or later)

The PDF FAQ that comes in the source only mentions;

CPU that supports SSE2 (Intel Pentium 4 or AMD Athlon 64 or faster)
GPU that supports Pixel Shader 2.0

One thing I forgot to mention is that I'm just using Xorg's ATI driver, I'm not using the proprietary ATI driver, so that might have something to do with it...
true. You meet the minimum requirements to start the emulator.
You won't get playable speeds in any game, but you can start it.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Hum for the pad you must use onepad. Then don't build PCSX2 with SDL 1.3 (and so gsdx). What is your GPU drivers? catalyst or opensouce ?
Hi gregory, I'm using Xorgs driver...

So remove this cmake flag or make it False?


What do you mean (and so gsdx), don't compile it? What cmake flag would I use to remove it?

xorg mesa driver does not work with zzogl.
GSdx does not work because wx depend on sdl 1.2 whereas gsdx depends on sdl1.3b
You can maybe see it with a command like that
ldd /usr/lib/libwx* | grep sdl
Ok all that just sounded like I can't use anything, LOL...

So the only hope is using the catalyst drivers?

By the way ldd /usr/lib/libwx* | grep sdl didn't do anything on my box.

Also this is what I have for my cmake flags in my build script;

mkdir -p build
cd build
cmake \
make all
make install
cd ..
I think you would be best off just dual booting into windows for the 3D rendering (even that might not help), Linux will only be able to use software rendering pcsx2 plugins (SDL is software too) and with the CPU already a major limiting factor the additional stress of software rendering will make everything slow and unplayable, I'd be surprised if you get more then 5-10fps on any game.

also not to be mean but your CPU/System is really outdated (AMD Athlon 64 TF-20) it's only 1.6ghz, even a Pentium 4 @ 3.2 ghz can't play many games on pcsx2 at full speed and that's with 3d rendering.
zzogl need opengl 3. Mesa is only 2.0... Maybe mesa 3.0 (or 3.1) will work better. So yes catalyst is mandatory for 3D. The opensource driver will be too slow anyway.

Where are located your wx library, it depends on distribution.

Just use default parameter for cmake.

Otherwise, I'm sorry but your computer is useless. On GSdx I got 25-30fps on a [email protected]....

Users browsing this thread: 1 Guest(s)