Thread Rating:
  • 2 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ANNOYING glitch in Rogue Galaxy (could be PCSX2 related)
This only happens in the 'Mafia' world, forgot the name of it. But when I'm travelling my character just randomly appears in the air, and then falls back down, he repeats this twice and then all of a sudden he just appears in air and he walks around and floats in the air and everything its so annoying because I can't get back down. Here is a pic:[Image: r8vuhk.png]
i5 3570K Ivy Bridge OC'd 4.5Ghz
GTX 760
CM Hyper 212+

Sponsored links

PCSX2 settings?
Could be too low calmping mode, try setting them higher.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Oh, I use 1888. What is low calmping mode?
i5 3570K Ivy Bridge OC'd 4.5Ghz
GTX 760
CM Hyper 212+
Try with the latest beta and post your settings.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Hi, I'm having the same issue at random points during the beginning of the Vedan stage of the game. I thought that opening treasure chests in the area somehow contributed to the problem but after playing around with it a little bit I'm not so sure about that...

Here are my settings. Please let me know if you need any other emulator/system info thx!

pcsx2, GSdx 3693 0.1.16 (direct3d11 hardware), lilypad 0.10, spu2-x 1.4.0, cdvdgigaherz 0.8.0 -- no cheats, no speedhacks
I actually know how to fix this one, it has nothing to do with the settings you used, seeing as I tried a ton of them when attempting to beat this game ( which I did ), instead the solution to this problem is to NOT walk on the rail road tracks, yes. If you walk slowly, and stay on the raised "sidewalk" you can get passed that part, if you have to fight monsters, stay on the raised " sidewalk " and let them come to you, or let your team mates kill the monsters for you. If this does not work, then nothing will. Remember, walk very slowly, and avoid the rail road tracks and you will get passed it.
Wow, such a simple solution! Thank you so much. I just got done trying your method and it definitely works. Problem solved!

I've really been enjoying this game and I would have hated to stop playing because of a glitch like that. Kudos to u! ^_^
Lol it feels awesome to help someone out. Enjoy the game, it's pretty sick.
I Have
Intel Core 2 Duo Processor
2GB Ram
Asus EN9400GT 1GB Graphics Card

And Pcsx2 Works Fine Smile

To Show It works On My PC I Have Added The Configuration Images And Screenshots(Use Hyperlink To See The ScreenShots) Smile

PCSX2 Screenshots



Attached Files Thumbnail(s)
I have been having the exact same problem, but staying off the train tracks having worked for me, I did an experiment where I walked away from the game after defeating the first morarty attack( on entering myna ), I didnt even move during the battle, because I used the Desert Wind 2. I still was jumped up onto the 'roof' of the map. If anyone knows what the issue could be I would greatly appreciate it. This is the second time I have tried to get through this game, the first time was years ago ( when i originally fell in love with it ) and the disc stopped reading on my ps2. This is completely maddening could it be the specific copy of RG? I don't understand this, how it has worked for others, and not even moving the glitch still effects me.

Users browsing this thread: 1 Guest(s)