AVX problem with i5 3570k
hi everyone Smile , i followed this site for years, never needed help or got troubles , also cause' i got a bad configuration time ago, so couldn't speak about performance or game playable, now i've these specs:
i5 3570k
8gb ram ddr 1600mhz
Nvidia geForce 560gtx ti 448

now, here is the problem. i've downloaded yesterday pcsx2 to play my loved gt4 Happy , i played hit for 2-3 races in arcade mode, just to try the smooth of gameplay, and that's worked pretty well, the problem is that i can only set SSE4.1 on gsdx, and during screen changes, like some freeze or slowdown randomly, this happens when i set my configuration same as this:


as said before, game run smoothly except some "joke" on load of tracks for example, when i press the button to join one race, it slowdown,or when the car goes out of track (i suppose for change of statment that slowdown). so i googled to find out something, but nothing about avx that doesn't work, only some forum that says similiar things but , not a way to fix it, maybe i'm wrong, anyway i found this:


tried it and game run very slow, i discovered that bob tff messed up the config, so i also modified texture to 4x native, because i've a screen over 1080p , and that's minimum required to don't see enormous squares over the screen xD, seems i'm playing psone otherwise. then my questions are:
1) why i cannot set avx on gsdx, i5 3570k i read support it, or maybe it's about the width of istruction ?

the error:
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
2)if this problem of avx can be solved, i'd see a lot of difference, in load phase, about what i talked before, would i have less slowdown, ecc. ?
3)why if i go in options screen and i set 480p or 1080i, the game shows garbage in 480p case, and in 1080i shows the screen stretched vertically, like i see it for the top-half, and the bottom-half is out of screen xD

sry for this long explanation, but i want to be clear as much as i'm able to. i hope i didn't choose the wrong section Happy

Sponsored links

you won't see any difference. AVX only works in software mode on GSDX which you don't need for GT4. Your best bet will be to enable the MTVU speedhack on the emulator.

if you want the game to look prettier, don't worry about the game resolution, just set a custom resolution on GSDX, however i must warn you it can be very memory intensive on GT4, so don't go above 720p if you can.
[Image: ref-sig-anim.gif]

Quote:if you want the game to look prettier, don't worry about the game resolution, just set a custom resolution on GSDX, however i must warn you it can be very memory intensive on GT4, so don't go above 720p if you can.

thanks for the fast answer Laugh

you mean, settings=> video (GS)=> plugin settings? there, there's D3D internal resolution, i flag off native and set on "or use scaling" 3x native, you meant that? or some other option, then the last thing.When i maximize the windows to play i see black sides, like when you upload one video on youtube, and the width or height it's wrong and doesn't fit the screen well.

i already activated mtvu btw Smile now playing on tv games is smooth and have no problem so Laugh. For the avx problem i understood what you meant, but why the plugin doesn't load? is it a new plugin? or just a problem in my case ?

edit: solved >.<' i've just modified gs window to full screen and "fill the screen" Laugh
i don't honestly know why it doesn't load! it is a bit weird. I have a niggling feeling somebody else had the same problem and resolved it, but i can't remember how.

as for the black borders at the sides, that's normal as the game is 4:3 as standard. You can change GSDX to "stretch" it to fill it out if you want, i think that's under Config->Emulator Settings->GS Window, you can set it to "Fit to screen/stretch" or "widescreen 16:9" Smile
[Image: ref-sig-anim.gif]

yes, as said before i got this Laugh, for the avx i hope you'll find out, so anyone won't mind to ask, because it's already explained "why" ;D thank you for the answers, and sorry for my english Laugh
Do you have SP1 for Win7 if you use that?
I think that was a requirement for AVX.
yep i'm using it win 7 ultimate 64 bit, i've just re-installed it yesterday cause amazon pack with new configuration arrived friday Laugh i've updated it to sp1 and now it works, thank you man, without your comment probably i wouldn't notice the change, so solved the mistery Wink

Users browsing this thread: 1 Guest(s)