Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
About the backwards characters in FFX(gameindex.dbf)
#31
No, it was never included. I made this thread to get it included but rama said in IRC they'd rather fix the emulation issue than add the fixes to gameindex.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply

Sponsored links

#32
I like his way of thinking. If having a complete save would be any help i have one with a fairly beefy party they are welcome to have
Intel Core i7-8700k @5ghz
G.Skill 16GB DDR4 @3600mhz
GeForce GTX 1080 8GB
Windows 10 x64
Reply
#33
(02-03-2015, 08:18 PM)Blyss Sarania Wrote: No, it was never included. I made this thread to get it included but rama said in IRC they'd rather fix the emulation issue than add the fixes to gameindex.

Oh right, I had forgotten about that. Well ignore the fact that I brought this back up then lol. Sorry rama! :-\
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU
Reply
#34
I put this on my todo list and forgot about it, sorry Tongue2
So yeah, properly fixing the problem is too big for now. It basically requires bit accurate recompilers without SSE.

So the recommended workaround is just EE round mode set to negative?
I can add this then.
Reply
#35
EE Clamping Mode to 'Full' or EE Round Mode to 'Negative' seem to do the trick. hellbringer616 mentioned that in the International version setting EE Clamping Mode to 'Extra + Preserve Sign' was what did it for him.

I think some testing should be done to confirm these fixes before they get added to GameIndex.dbf
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU
Reply
#36
(02-24-2015, 08:59 PM)rama Wrote: I put this on my todo list and forgot about it, sorry Tongue2
So yeah, properly fixing the problem is too big for now. It basically requires bit accurate recompilers without SSE.

So the recommended workaround is just EE round mode set to negative?
I can add this then.

what does bit accurate mean? I thought everything is bit accurate...
Or do you mean the FPU differences between ps2 floats and x86 floats (as NaN and stuff)?
Reply
#37
(02-24-2015, 09:07 PM)karasuhebi Wrote: EE Clamping Mode to 'Full' or EE Round Mode to 'Negative' seem to do the trick. hellbringer616 mentioned that in the International version setting EE Clamping Mode to 'Extra + Preserve Sign' was what did it for him.

I think some testing should be done to confirm these fixes before they get added to GameIndex.dbf

It was the International version that clamping modes DIDN'T fix for me.

What we need to confirm is if there is a case where EE round to negative DOESN'T fix it.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#38
Just like the only thing that works for you is EE Round Mode set to Negative, the only thing that worked for KrossX was setting EE Clamping Mode to 'Full'. However his post over at NGEmu speculating about different options made me wonder if maybe different CPUs meant needing to use different settings to fix the issue:
KrossX Wrote:New test on rev2340:
No changes, fixed only with EE Clamp: Full. Nothing else matters.
Using AMD Athlon II X2 240.

Perhaps EE: Normal + Rounding: Nearest fixes it on Intel CPUs?
KrossX, which AMD CPU do/did you have?

Then there's this post from another user:
Princess Garnet Wrote:Setting the round modes to "nearest" didn't fix it.

Setting it to "negative" mostly did (I'll explain below).

....

Now, I say "mostly" fixed because while the characters and attacks I tried (mostly melee) were how they should be, once I summoned Bahamut, him and Yunalesca were still facing the right way, but he'd spin around when attacking her facing away from her. I'm not sure if this would effect Auron's overdrive from operating correctly, but I think it should work since the characters themselves were facing the right way.

So Blyss Sarania are you sure that setting EE Round Mode to Negative fixes the issue completely when you play FFX?

(07-07-2014, 05:08 PM)Blyss Sarania Wrote: The fix is setting EE rounding mode to Negative. Turning the clamping modes up has also been reported to work - but for me I had to change the rounding mode.

I played through the entire game with the Clamping modes turned all the way up, I applied negative EE rounding on my first backwards battle and never turned it off and had no problems.
When you say 'Clamping modes turned all the way up', do you mean you had both EE and VU Clamping Modes maxed out? I ask because apparently at some point in PCSX2's life, the Clamping Mode settings had tooltips to go along with them and this is what it said for EE Clamping Mode set to Full:
PCSX2 Wrote:Full: Attemps [sic] to emulate large numbers correctly for the EE's FPU. VU's clamp mode should be set to "Extra + Preserve Sign" for this to work best. (But still work for most games even with "Normal" VU clamping)

Either way it seems that changing EE Round Mode didn't work for KrossX so I'm thinking we need to include both 'fixes' in GameIndex.dbf. We could also do some more testing with the newly-minted Bug Squad to make sure this information is correct and to what extent each setting fixes the problem on different PCs.

P.S. Is there a reason PCSX2 doesn't default to maxed out clamping modes (EE Clamping at Full and VU Clamping at Extra + Preserve Sign)? Does it slow down emulation too much or cause glitches in other games?

__________EDIT__________
I found this:
(06-18-2012, 06:58 PM)Alexander Wrote: Final Fantasy X - Characters are turned the wrong way in battle.

Fix : In EE/IOP and VU, change the Advanced Recompiler Option to Negative.

Fix 2 : In EE/IOP change clamping to full and in VU change VU to Extra + Preserve Sign

I know that setting EE Round Mode to Negative was enough to fix it for you Blyss but I'd like to know if KrossX tried setting both EE and VU Round Modes to 'Negative' to see if that also fixed it for him.

Also I find it funny that a post from 2012 already had both of the known fixes listed. XD
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU
Reply
#39
I think full clamping reduces the performance a lot. You need some additional instructions.

Best example is in the developer blog:
On x86-FPU:
Sqrt[-4] = NaN
On ps2-FPU:
Sqrt[-4] = 2

Workaround for x86 to emulate ps2. (FPU emulation):
Code:
PS2sqrt(value)
{
clampedvalue = clamp(value);
absvalue = X86abs(value);
return X86sqrt(absvalue);
}

So it needs three steps instead of one:
clamp -> check for all other fpu violations (as min and max values),
X86abs -> X86 abs function removes sign,
X86sqrt -> x86 root of second order
Reply
#40
Yeah I based my questions about the possible issues with clamping on cottonvibes's blog post in the developer blog about clamping. I'm just wondering if this is still the case though? What games are known to break with high clamping? And does high clamping slow down down current hardware enough for it not to be the default? If it fixes some games (and doesn't break any) and doesn't slow down current hardware too much, I'd love to see it be the default.
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU
Reply




Users browsing this thread: 1 Guest(s)