All PCSX2 installations suddenly don't detect controllers... kinda
A really bizarre issue started happening today and I can't find a fix for it.  I run two PCSX2 installations, one 1.6.0 setup and one setup for whatever the latest 1.7.0 build is - I update it regularly.  A few hours ago, both installations stopped detecting my controller.

I run DS4Windows and everything was working perfectly, but now no inputs work in any game in any PCSX2 installation.  The weird part is that the Gamepad Settings menus do detect the controller and even allow me to map buttons, but as soon as I boot a game it acts like no controller is plugged in.  I know the controller is working because other games and emulators do detect it and work perfectly with it, and the controller mapping screen in PCSX2 does detect it and work perfectly with it as well, but no games detect a controller anymore.  My controller is wired using a USB cable so there's no weird Bluetooth shenanigans going on here.

PCSX2 is now completely unusable for me.  Any idea what the issue might be?  Maybe I accidentally pressed a "lock controller" button?  I know for a fact that I did not change any settings in DS4Windows, no drivers on my computer changed, nothing like that.  Something that might be related is the fact that before this issue started, my controller would constantly disconnect and refuse to reconnect when using DS4Windows and PCSX2 together.  When using DS4Windows and any other program, it would never disconnect.  This "no controller detected" issue did start after the most recent controller disconnect, so I don't think it's a coincidence.

Just in case this was a very very obscure DS4Windows, I did ask for support there and it was suggested that it was a PCSX2 issue.  It clearly is as no other program has this issue.

Edit: I have some more info that might be of help.

First, PCSX2 seems very self-contradictory about whether a controller is plugged in or not. You can see here that I can map controls just fine, and they map to XInput Pad 0:

However, launching the controller diagnostics for XInput Pad 0 shows nothing is plugged in:

Yet the menu right above that shows that there's 24 mappings for it, which there are:

When booting any game or the BIOS, the log says:

"PAD: Warning! No controls are bound to a currently attached device!
Please attach a controller that has been setup for use with PAD or go to GamePad Settings and setup new controls."

I thoroughly checked both DS4Windows and PCSX2, absolutely no settings were changed in either program. It seems that there's some sort of internal code conflict here as some systems say the controller is working but other say no controllers are plugged in. I swear I didn't change anything.

Update: the controller started getting recognized again, no settings changed anywhere. Disconnecting issue is still a thing.

Sponsored links

This just happened to me but PCSX2 doesn't detect my controller input for button mapping.
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)