An interesting problem I am having with audio when recording.
This is my first time using the emulator so I'm sure I'm just messing up something fairly simple here, but my question wasn't answered in the sticky topics I read so I figured I'd ask.

I wanted to record Growlanser Heritage of War for a Let's Play series, so I booted the game up and it runs and sounds fine, but I found when reviewing the recordings I made that character voices and several sound effects have a crazy echo to them. This echo ONLY appears in the recording, as everything sounds fine while playing, so I don't think it is a hardware issue of any kind (which is why I haven't included my PC specs).

Initially I suspected it might be a conflict of some kind with Bandicam, so I tried using xSplit set to local recording mode to test this and the same echo was present in those recordings as well. I also haven't made any changes to the audio plugin, short of lowering the volume to 50%. Anyone familiar with this problem or know how I can fix it?

Sponsored links

Try setting the sound plugin to async mode and see if that helps.
you don't have by luck a microphone on your desk that records your sound and the microphone input is saved as well?
I actually have a headset and not a desk mic, but I'll try disabling it all the same and see if that works, as well as trying async mode, and report back.

EDIT: Negative on both suggestions, and their combination, I'm afraid. Sad
Can you still please try to turn the sound off on your boxes/headset or just unplug everything? So that the internal sound is still recorded but you can not hear it? I have the feeling that recording an sound echo only using software is almost impossible. At least if you don't intend to record one.

Do you have other software that interacts with sound in-/output? Skype?
I can unplug the headset and test. I'll upload a file showing what I mean about the audio if that doesn't fix it, as it sounds like an echo to me but maybe you guys can identify it as something else. I'll post the results shortly.

EDIT: Recording with my headset unplugged recorded no sound at all in Bandicam, so I'm testing some options in it.
EDITx2: Seems I cannot begin capturing game audio without at least the speaker part of my headset plugged in with Bandicam
EDITx3: I . . . don't even know how to respond to this. So, I started the recording with the speakers plugged in, then removed them after I started capturing video, annnnd . . . the echo vanished after the speakers were unplugged. ._. I'm going to try recording with my other headphones and seeing if that has an echo as well.
EDITx4: Echo is there with the standard headphones (no mic). I'm going to test the remove thing with these as well.

EDITx5: Yep, removing the headphones fixed the echo again. X_X Somehow, even without a mic, just having speakers hooked up is generating the echo in the recording. This is certainly unexpected. Thank you for helping me identify the problem, it's greatly appreciated. Smile You . . . wouldn't happen to have any ideas how to get around this, would you? I didn't respond to the question earlier, but there are no other programs running that interact with my audio, Chrome on certain occasions excepted; I shut off Skype before recording. It's not a problem if you don't have any ideas, as I can record my audio on my netbook and merge the files later.
That indeed is an interesting issue. Nothing is coming to mind as to why it would echo with speakers. Are you sure there's nothing messing with the audio? Drivers or audio processing programs?
I can certainly attempt to update my audio drivers, which I'll look into after I post this. There are no audio processing programs open that I am aware of. Steam can make use of my speakers, but it wasn't open when I did the original recordings this morning.
It could be some software chatting with some server. Audible lag (signal + lagged signal = echo) should have some tens to some hundreds of ms delay. This is a typical internet connection response time. What happens if you turn off your internet connection/disable the network adapter?

Try to turn every bit of software off. Especially sound producing or recording software. Also utilities that are normally installed with the drivers (as Realtek Something Advanced Audio Center or whateva). Does this happen only with pcsx2?
I've had no echos recording anything else, so thus far the problem is exclusive to recording Pcsx2.

Realtek HD Audio Manager doesn't pop up anywhere unless I manually run it, which I did earlier while attempting to determine if I needed to update my audio driver (which appears to be up to date) and I noticed some options in it I hadn't messed around with before. In particular, there is an option for 'headphone virtualization' (is on), 'Tie up same type of input jacks as an input device'(is on), and 'separate all input jacks as independent input devices' (is off). I'll try cutting my connection and recording, and turning off headphone virtualization and post the outcomes.

EDIT: Tested both and it seems that 'Headphone Virtualization' is the problem! I tested both unhooked from the Internet and with it off and got no echo, then tested again with just virtualization off and still had no echo. Just gotta test with my headset now to make sure. Smile

EDITx2: That fixed it! I tested recording with the headset AND with my mic enabled and there was no echo. Thank you both so much. \ ^_^ /

Users browsing this thread: 1 Guest(s)