Analog stick and save states? trying to figure this one out.....
So I have an issue where apparently my left analog stick switches to the functionality of the normal d pad.... it happens in castlevania: Lament of innocence..." (it usually only happens either when i start the game, or it has happened midgame, but rarely... i have seen it also happen when im scrolling around in the map with the analog stick, but it has been hard to actually pinpoint something im "doing" to make it happen, because as i said, once, in the middle of a battle, it reverted to dpad function, so the left analog stick, that was supposed to allow me to move, was opening up my items menu)

So, as odd as this problem is, the ways i have fixed it are odd as well.... although it doesnt consistently solve it, if i keep loading different save states, the problem seems to fix itself in one of the saved states eventually, i just change the state and load and try moving around until at some point it works properly. The problem isnt consistent either, for instance, just because it was happening on save state 4, for example, the next time i load the game on that state doesnt mean the problem will still be there(even if i didnt actually save a new state on that slot)

I am using Lilypad svn r3878 0.10.0 for the controller, i havent tried the other plugin, since i have been able to fix the problem, and the problem is off and on to begin with, so i dont know if switching would solve it... I just thought it was a very weird issue, worth mentioning, possibly as a bug....

My bigger question would actually be what do save states have to do with the controller? how would changing save states fix the issue im seeing? And why would this issue pop up out-of-nowhere to begin with....

Dunno if its worth mentioning, but i may as well, as it could be related. I also have an odd issue where when i change some settings the console will spit out an error saying that it couldnt save, access is denied( i have seen that im not alone in this problem, and it probably has to do with the location of my settings folder, i have reinstalled and tried running as admin, and tried moving that folder, but the error still shows up). Funny thing is tho, all of my settings stick, i havent seen a problem with a setting not staying yet. On top of that every now and then when i start pcsx2 it seems to think the program has never been run and starts the configuration tool again and i have to change all my settings again... annoying....

Anyways, I'm done rambling. Thoughts?

Sponsored links

Hey man i cant configure the LX, RX and all....
please help!

It's an emulation problem. Try changing the clamping mode for VU and EE to Full and Extra+Preserve Sign, or even change the roundmodes to negative. After doing these changes load from a memory card save and not a state because the latter might cause them to not take effect
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)