Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Another Star Wars Jedi Starfighter problem
#1
I have another problem with Star Wars Jedi Starfighter, however this problem occurs on an actual PS2 as well.  I don't know if emulation can fix this, but I thought it was worth mentioning.

After completing the mission "Demolition Squad", there is a pre-rendered cutscene that is supposed to play.  About 5% of the time, the entire screen turns red and stays that way.  I have to play through that mission again and hope it doesn't happen again.

Here's the thing - this has happened to me several times on a real PS2 console, so I think it's a flaw with the game itself, not the emulator.  The framerate changes, so it's not a crash.  I actually bought a new PS2 thinking it was a hardware failure, but it happened again.  I was really surprised when I saw this on emulator.

I've attached a screenshot of the red screen glitch.  Since this is completely random and cannot be triggered intentionally, I was unable to get a GS dump or a log when the issue occured.


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
A ps2 emulator is only trying to emulate a ps2 with better quality graphics ans sound. I think the problem won't go away and might be worst.
CPU : I7 6700 3.4 Ghz
GPU : Gigabyte Geforce GTX 1050 TI
SPU : Realtek High Definition Audio
RAM : 16 GB
Os : Windows 10 64 Bit
Emulator : PCSX2 1.5 
Reply
#3
Quote:I was unable to get a GS dump or a log when the issue occured.
think about it next time.

but if one of your friends owns the game, or if someone here could confirm that game bug, it could be interesting
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
This game actually have many bugs. Smile For example it call ps2 exit() right after you finish bonus stage. You can fix it by nop on jal Stop__12CTaskManagerFv instruction.

About your issue. There 2 known bugs that can cause this. One is that game not clear framebuffer on movie-display/movie-startup. Second is random node corruption while performing CSGNode (AddChild).
No idea that can be fixed in pcsx2.
Reply
#5
maybe some specific patch could correct the framebuffer clearance for fmvs. but that would clearly be a specific hard-coded one.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
I should mention that the "Skip MPEG" hack doesn't prevent this from happening.
Reply
#7
(05-24-2018, 12:29 AM)goody_fyre11 Wrote: I have another problem with Star Wars Jedi Starfighter, however this problem occurs on an actual PS2 as well.  I don't know if emulation can fix this, but I thought it was worth mentioning.

After completing the mission "Demolition Squad", there is a pre-rendered cutscene that is supposed to play.  About 5% of the time, the entire screen turns red and stays that way.  I have to play through that mission again and hope it doesn't happen again.

Here's the thing - this has happened to me several times on a real PS2 console, so I think it's a flaw with the game itself, not the emulator.  The framerate changes, so it's not a crash.  I actually bought a new PS2 thinking it was a hardware failure, but it happened again.  I was really surprised when I saw this on emulator.

I've attached a screenshot of the red screen glitch.  Since this is completely random and cannot be triggered intentionally, I was unable to get a GS dump or a log when the issue occured.
I think I found the solution. I’ve only experienced the glitch when I finished the mission with both the bonus objective and the hidden objective completed. So maybe try getting them one by one and see if that works.
Reply




Users browsing this thread: 1 Guest(s)