Ar Tonelico 2 Melody of Metafalica Possible Bug?

As this is my first post I'm not sure where to put this question/problem on the forums as I'm not sure if this qualifies as a bug or not.

I have the latest beta of PCSX2 (0.9.8) and I'm attempting to run Ar Tonelico 2 on it as a ISO but the game keeps crashing.

The ELF of the game is SLUS_217.88;1 and I am using a fairly high end rig with quad core processors on Windows 7.

I have fiddled with the settings in the program but the result is the same.

I'm not sure how to apply the patch after attempting to apply it on the ISO file itself and I'm stuck at this point on what to do.

If it helps, I'm using DAEMON tools as the emulator although I don't know how to save a screenshot.

I'm also usng all the latest plugins and GDSx as well along with the most current DirectX version as well.

Any help in resolving this dilemma would be greatly appreciated.

Thank you Smile

Sponsored links

Okay many many things wrong with this thread:

#1: Don't use daemon tools for pcsx2. Unmount the ISO from daemon tools and use the pcsx2 iso loader.

#2: Not sure what patch you're talking about... if you're talking about a patch built into the emulator, it will auto load it when you load the game.

#3: If you're going to give the specs of your machine, don't say "fairly high end rig"... Fairly high is a relative statement and differs from person to person... and many people think they have a fairly high end machine and are quite wrong Wink. CPU, CPU speed, Ram, video card, and windows version.
Thanks for answering so quickly. Smile

In repsonse to your question about the patch, I was referring to the gamefix in other topics about Ar Tonelico which apparently fix a problem when you go to fight the last boss of the game.

I also tried running Ar Tonelico 2 in the ISO Selector in PCSX2 but the result was the same, I even tried running it with and without the game fix in emulator as well but it still crashes. Sad

About my machine's specs are as follows:

DirectX Version: 11

BIOS: Award Modular BIOS V6.00PG

Processor: Intel® Core™2 Quad CPU Q9450 @ 2.66GHz (4 CPUs), ~2.72GHz

Memory: 4096MB RAM

Graphics Card: ATI Radeon HD 4800 Series.

This is directly from dxdiag.

I'm not sure how to solve this problem, short of repurchasing the game from the US and playing the game directly from the CD itself As I had to get rid of the original CD when it got too scratched.

The problem itself is that the game crashes right before it loads up (after the Playstation 2 Intro logo).

Any help to allow me to enjoy this game normally would be appreciated.

Thanks! Laugh
You may have made a mistake when applying the patch. Try your good copy if you still have one.
Otherwise, please attach a screenshot of the PCSX2 console output that shows what it does before crashing.

Users browsing this thread: 1 Guest(s)