Arch Linux: Sound and Pad Not Working

I'm running Arch linux. I have an Nvidia GTX 960 graphics card, Intel Core i5 Sandy Bridge CPU, 32 GB of RAM, and a SSD. The sound output is built into the motherboard. I am also using a generic (non-sony brand) PS2 controller via USB. It works fine using Mednafen for PS1 and SNES games.

I'm running into two problems:
  • LillyPad's Plugin Settings window is not opening. When I go to Config -> Controllers -> Plugin Settings, nothing happens. However, if I change the PAD driver to OnePAD, the settings window opens just fine. But then the problem is with OnePAD, it is not detecting my controller's Start, Select, L3 and R3 buttons at all. Every other button works fine.
  • The sound output is garbled/static. It sounds nothing like the actual sound of the game; it's entirely staticy chirps. The only driver option (other than NULL) is SPU2-X. I have tried changing all the settings to no avail (including interpolation, disable affects processing, module, portaudio api, SDL api, and Sync mode). The only audio I get is either no sound at all or the staticy chirping sound.
I would appreciate any advice! Thank you!

Sponsored links

Officially lilypad doesn't exists on Linux.

Onepad depends on the SDL version to detect the pad. Are you sure, you got the latest

Did you install a *32 bits* sound plugin ?
Got it! I installed 32bit alsa and pulseaudio packages. The audio works perfect now!

I'm using the latest version of pcsx2 from the arch linux repositories. OnePAD 0-Dev 1.1.0 [libonepad-1.1.0]. Like I said, it detects all buttons on my controller except for Start, Select, R3, L3. When I run `jstest /dev/input/js1` the buttons work:

Start: Button 9
Select: Button 8
L3: Button 10
R3: Button 11

But I'm not sure why OnePAD does not see only these buttons.

Thank you!
It could depends on the SDL version which use /dev/input/event* not the old js interface.

Edit: check permission of /dev/input/event*
Which is your SDL version ?

Users browsing this thread: 1 Guest(s)