Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Armored Core: Nexus Water rendering bug
#1
It also happens in Armored Core 3 and Silent Line: Armored Core as well, but not Armored Core 2 and it's expansion for some reason
My PC uses an i3-3220 @3.3GHz, a GTX760, 8GB of Ram.
-PCSX2 GS Settings:
*EE/IOP and GS are on default settings
*Speed Hacks has EE Cycle set to 2, VU Steal Cycle set to 1
*All other speed hacks are checked except for MTVU Hack
*Automatic Game Fixes enabled and manual ones are unchecked

-In the GSDx Plugin, following hacks are enabled:
*Align Sprite
*Fast Texture Invalidation
*Framebuffer Conversion
*Merge Sprite
*Unscale Point and Line
*Wild Arms offset

The rest is off. I've tried tampering with "Alpha" and "Alpha Stencil" to no avail. I've also tried to turn off the hacks but it also doesn't fix the water.

The photo has been taken in Direct3D11 Hardware mode. The only way I've found to fix it was to change to Direct3D11 Software, but I'd be stuck with a jumbly pixel mess and slow gameplay. Is there some solution to this bug that doesn't involve going into software(which just makes the game downright unplayable)?


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
OpenGL shouldn't be much slower than DX11 for you. What are your GSDX settings when you're in OpenGL Hardware mode? Can you take a screenshot.

Also try turning off all those GSDX hacks, unless you know they are needed, they shouldn't be on.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
OpenGL HW is giving me half speed
   
       

In Direct3D the game runs fine, with the exception of a few special cases(3 Armored Cores on screen, heat waves over the screen) I just wanna know if it's possible to fix this water bug.
Reply
#4
OK turn all those hacks off for a start, you don't need those. Also turn your resolution down to Native x2 for the moment to see if that helps.

Disabling Blending Accuracy could be worth trying too, although I'm not expecting much.

Also can you check in your Nvidia control panel to make sure the "Threading optimisation" is enabled?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
[quote pid='583989' dateline='1522516081']

Disabling Blending Accuracy could be worth trying too, although I'm not expecting much.

Also can you check in your Nvidia control panel to make sure the "Threading optimisation" is enabled?
[/quote]

I think it's set to auto
   

But putting the game in OpenGL is not solving the water stripes
EDIT: I've set it to ON, no difference whatsoever
Reply
#6
Did you disable all those hacks and lower the Internal Resolution?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(03-31-2018, 07:25 PM)refraction Wrote: Did you disable all those hacks and lower the Internal Resolution?

Yes I did, the result is the same as D3D11, but with worse performance because this game doesn't like OpenGL in my machine
Reply
#8
So turning off the hacks made the lines come back?

by the way, what version of PCSX2 are you using?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
With the hacks on or off, the lines are still appearing on OpenGL, I've edited my first post half hour ago. One thing I notice is that it's like some sort of buffer drawing over itself making these lines appear.

Right now it's an "old" git, but it's PCSX2 1.5.0-20180222002054(pcsx2-v1.5.0-dev-2292-g10ebe1665-windows-x86)
Reply
#10
oh okay, hmm not sure how to solve it then.

The only thing I can suggest is try the newest git and see if it's resolved, but I have very little hope for that. You might be stuck with software mode, or putting up with the lines.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)