As of 10 or so updates ago, savestates have become nearly unusable for me
#1
Starting around 10 or so 1.7 updates ago, savestates have become nearly unusable for me because of one frustrating issue - if I load a savestate of any game more than once, the entire emulator crashes, producing a crash log.  All games do this regardless of cheats enabled or disabled, settings, renderer, etc.  Basically, if I want to load a savestate a second time after booting a game, I have to fully close PCSX2, reopen it, relaunch the game, and reload the save state.  This was not always the case and this can't be intentional.  This is especially frustrating for speedrunning.  I'm a speedrunner and I'm loading a savestate to reset the run, and now I have to fully close and fully reopen the emulator whenever I want to load my savestate a second time.  Since it produces crash logs, I've attatched one for Sly Cooper and the Thievius Raccoonus, a game that hasn't had a single issue for me since 1.4.0 stable, and I disabled my cheats for it, so this should either show the issue or help find it.


Attached Files
.zip   crashdump.zip (Size: 281,64 KB / Downloads: 42)
Reply

Sponsored links

#2
No problem here(tried loading and saving multiple times and doing that on different games without exiting pcsx2

Just for a text,try downloading the latest beta and extract into a new location(so settings,memory cards or anything extra).Just point where the bios is and try running your games
Reply
#3
No, that's not the problem. The problem is when you do the following in order:

- load any game
- make a savestate
- close PCSX2
- reopen PCSX2
- launch game
- load savestate
- load savestate again

It only crashes if you close the emulator after making the savestate. However, this isn't true either, as it only happens sometimes. While testing this issue, I've made savestates that don't crash if you load them more than once, but then the next savestate I made followed this issue.

I did start fresh with new files, keeping my games/cheats/configs/etc and the issue persisted. The configs can't be the issue as I haven't changed any settings in any of the configs for months and this started a few weeks ago.

Edit: I should be more specific. If I load a game and make a savestate, I can load it however many times I want to without crashing. However, as soon as I close PCSX2 and reopen it, the issue persists until I delete the savestate, shut down PCSX2, reopen it, and make another savestate, and then I can load that one as many times as I want.
Reply
#4
Nope,did this order multiple times and also tried adding some multiple loading and saving to the mix along with creating a save state on exit and loading it but pcsx2 did not crash
Reply
#5
I don't have the game you're mentioning so I've tested with few random ones I do have at hand. I'm unable to reproduce this either. Perhaps there's something in emulog that can help narrow down whatever is happening.

Super quick google suggests that the error is an access violation. Maybe something's blocking it; IIRC correctly, ESET antivirus (as an example) really doesn't like pcsx2 for whatever reason.
Reply
#6
The weird part is that this sometimes doesn't happen. Some savestates I can load repeatedly with no issue, some I can't even load once, and others are fine for the first 20 or so loads but then start doing this. I hate bugs like this, the ones that no one else can reproduce.
Reply
#7
I've found the problem - it's USB Keyboard. If the first emulated device is "HID Keyboard" and you also have "Load State" mapped to a keyboard key, this happens. Going to open a GitHub issue about this, but FINALLY I can use savestates as long as I remember to completely disable keyboard emulation.
Reply
#8
So I've tried only using keyboard and still unable to reproduce your issue no matter how many times I try. I have USB keyboard that's showing up as "Keyboard: Keyboard" in the devices section and is first. I'll try to dig up your git issue to see if there are more detailed reproduction steps...

You should try a different keyboard as a test as perhaps it's not the keyboard issue but something like keyboard's software (if you're using Razor's cloud service, or something else) that's fighting for control.
Reply
#9
It only happens if you press hotkeys while USB Keyboard emulation is active. I realized this when I tried to disable Framelimiter with F4 and it crashed in the same way. So I tried "next savestate slot" and that crashed. Every single hotkey I tried crashed the emulator. Then, when I changed HID Keyboard to None, all crashes completely stopped.
Reply
#10
Oh, you must be emulating something on the USB1 for your controller... They are probably fighting with 'regular' keyboard functionality.
I use Xbox controller so it's mapped to Controller 1...

IIRC there was a biiiiiiiiiiiiiiig USB device merge into QT a month ago, which probably correlates with your crashes starting. Does sound like an edge case bug though, fair enough assuming someone configures it in the way you do. Please try to get full reproduction steps listed in the bug report as most folks will play with some sort of controller and not map USB keyboard as a controller option.
Reply




Users browsing this thread: 1 Guest(s)