Assistance with Persona 4 Please
Hello does anyone have experience with running Persona 4 on Mac and would be willing to assist a complete computer illiterate? I’m experiencing issues trying to run it and unfortunately all the guides I find online are either too advanced for me to understand or are meant for Windows users. I should have played it when I bought it and before my ps2 died but oh well here we are. I have the pcsx2 fully set up, I believe I'll only need help figuring out which settings and plugins to use for running this specific game.

The issue in question is that while the logo screens display just fine, and the title screen displays beautifully (it doesn't even lag), the opening cutscene (and thus I assume other cutscenes, I haven’t played past the title screen) have issues. At first it flickered violently while displaying a few shots of the graphics, and after a few settings were changed, it now merely fades fully to white. All the while, sound works perfectly, perhaps with very slight lag, but that's to be expected. I understand I could simply skip the cutscenes, but I’ve been looking forward to this game for ages and I wouldn’t want to miss any of the experience, and my ps2 has fallen into disrepair making an emulator necessary. I also worry that this issue could affect gameplay and scenes necessary for plot advancement, so I would be very grateful if someone with a great amount of patience could help me fix this problem. Discussions of this sort just have a lot of assumptions about terminology that I end up completely lost when looking for help. Thank you in advance.

Sponsored links

EDIT: Ignore this sentence, realized there is a Mac section:
I'm not sure if you'll find support in these forums for the Mac version but here we go...

(Note: I don't have OSX or no way to test what I'm saying but should be able to help anyways Smile )

What version do you have installed from ?? 0.9.7 or 0.9.6?? AFAIK you should DEFINATELLY have 0.9.6 as it is more stable and feature-complete. If you have 0.9.7 uninstall it and install the 0.9.6 version. If you have Snow Leopard install all the additional plugins (zzOGL 0.1.0 and others listed).

Come back with any progress/help needed Smile
Thank you for the response, I appreciate it. I already have 0.9.6 pcsx2, though I did try uninstalling and reinstalling that version just in case. I believe I already have all of the plugins listed, but I'll list them just in case:

ZZ OGL PG 0.1.0
OnePAD 1.1.0
DEV9null Driver 0.4.0
USBnull Driver 0.6.0
ZeroSPU2 Playgound 0.4.6
Linuz iso CDVD 0.9.0
FWnull Driver 0.5.0

I've manipulated multiple setting and even the BIOS (in case that does anything), but like I said all it does was cause it to stop flashing and instead just be completely blank until the title screen. I did play further, and dialogue seems intolerably laggy and the sudden blank screens where cutscenes should be were completely disruptive to playing the game, so it may be a speed issue in general causing the problem, and I wouldn't know how to correct that either. Just in case it's helpful, the settings reset to default, so I'm attaching a shot of the original problem.

[Image: 2mxfp1z.png]

(I'm really sorry, I have no idea how to resize it, and it wasn't showing up when I attached it)

It shows this screen, with flashes of the actual scene interspersed. I don't know if that helps at all though. I don't understand the terminology being used, so I get completely lost whenever I try to look up how to speed it up in case that's the problem with these graphics, much less looking up to see if this flashing is a common problem (it seems to be, but most of the advice is for Windows and doesn't transfer over well because all of the suggestions involve downloading Windows programs and settings for Windows plugins). Anyway thank you so much for the help so far but unfortunately it's not yet corrected the issue.
Yes, you do seem to have the right plugin selected, can you post a screenshot of the Graphical plugin (zzOGL PG) configuration?? To get there go to the Plugin selection screen from PCSX2 and next to the Graphics entry with zzOGL PG click configure.

Which Mac do you have?? Do you know the specs or at least the year/month (i.e. mid 2011)?? Also what version of OSX are you actually running?? What version of XQuartz and Nvidia CG toolkit do you have??
Thank you. Let's see... okay here's the screenshot of the configuration.

[Image: 33pegja.png]

When I fiddled with certain settlings, it did go a bit faster, but not by very much at all, and that was what made the cutscenes display nothing but a white screen instead.

According to the system, it's a MacBook Pro, early 2011. I'm running OS x 10.8.4 and version 2.7.4. of XQuartz. I'm less certain of the Nvidia CG toolkit, mostly because I couldn't find it despite having installed it in the past. I re-installed it just in case (with no change in the game) and the installer said Cg-3.1.0013, so that's most likely the version. I hope that was the information you wanted.
Oh wait, changing settings made it screw up?? I think I misunderstood all along, will be back shortly with a "reset-to-default" step by step help Smile little busy now
No problem on the delay, but I think you misunderstood. It was messed up initially, changing settings merely made it screw up in a different way. It was flashy as I described in the first screenshot from the beginning with no change, then I changed it, and it changed to white screens while still not showing the cutscenes, and still remaining horribly laggy in the rest of the gameplay. Sorry if I worded it poorly to make you think that.
Ok, I'm back into understanding, that's what I thought all along, reading your post again I got what you wanted to say, my misunderstanding Smile Could you check if you have frameskip enabled and, if so, disable it?? What speedhacks are enabled?? Also try playing around with anti-alising, that is a big slowdown on your system, specially if it's 13" Smile
Oh, I just saw that you replied my bad, this time it didn't email me. I'm not sure how to check if frameskip is enabled. I may have found the place, but I'm not sure how to disable it if it is the frameskip. It's under the CPU section, And under the topic of Frame Limiting (F4 switches in-game), there are three options - Normal, Limit, and Frame Skip. It is set to Normal, so Frame Skip may already be disabled. Otherwise I don't know how to check it or disable it.

For speed hacks, EmotionEngine (EE) Sync Hacks is sets at 1.5 Cycle Rate by default, and anything less or more causes the game to start in nothing but white screen, not even showing the logo screens that previously worked. VU Cycle Stealing (Speedup for 3d geometry) is set at 0: No speedup, mostly because it keeps going back to zero after I exit out of the application. I have tried it at 1-4 and none of them have had any noticeable change. Enable IOP x2 Cycle Rate, INTC Sync-Hack, and Idle Loop Fast-Forward are all enabled, and disabling them has had no change. I had Status Flag-Hack and Min/Max Hack enabled as well, but they are currently disabled as they also disable when I exit out of the application.

I tried anti-aliasing at every setting and unfortunately none of it corrected the issue. None of these changes have caused it go into the white screen though, it has simply remained with the half white/half black screen with scenes flashing in intermittently. Sorry to be any trouble, but unfortunately none of that worked.
Yes, frameskipping is disabled.

Well that sucks really, I'm going to blame the Mac port for being incomplete...

In the meantime try version 0.9.7, it might have different issues or work fine, I'm not sure I can help you more (or that anyone can other than the port author) Sad

Good luck and get back to me with results Smile

EDIT: I forgot to add that the higher the AntiAliasing the slower the game will go Smile

Users browsing this thread: 1 Guest(s)