Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Associating a DualShock 4 controller with Windows 7
(01-03-2015, 09:28 PM)Tomdominer Wrote: Ok, I've followed this and am still having problems.

So, my DS4 seems to pair ok, and I see it under the bluetooth devices as a "wireless controller" but it does NOT appear under the game controllers section of the device manager at all. It does when I plug it in via USB.

I have the appropriate Microsoft Accessories and .NET installed.

Also, I'm using this dongle from amazon:

Any ideas? It's driving me crazy!

I had the same problem on Windows 8 and it seems that I sorted it out.

When pairing the gamepad to your BT adapter, at some point windows will ask you to create pairing code. Use "0000" and DS4W detects instantly.

Tested on two PCs, different BT adapter, same gamepad.
I hope this will help other users.

Sponsored links

(12-11-2014, 08:46 PM)Quardah Wrote: Hello everyone.

I am still struggling with the issue. I stopped trying now because i've hit a wall. If someone could help me out a little i would appreciate. Many thanks again.

Hi. I'm not sure if I'm late or not, but here's how I solved exactly the same issue on Windows 7 x64:
Before step4, except turning off DS4Tool (or DS4Windows) you will need to exit this programs:
1) Skype
2) Steam
3) scpserver.exe (from Process list in Task Manager, this thing is started at launch with DS4Tool)

All of these processes intervene with Bluetooth stack and will prevent gamepad from pairing.
Hey guys, thanks for the replies.

I never got a "pairing" message, so I'm gonna try the steam / skype stuff tomorrow!

Wish me luck!
Sadly, this didn't work. It still doesn't do the full pairing...
Just wanted to chime in to say I'm having the exact same problem; I pair my PS4 controller, it shows up for a little bit, then disappears completely. When I push the PS button, sometimes the light stays on completely, and sometimes it pulses softly. Like the others, I feel like this means it's paired somehow, but it doesn't show up in any of my devices lists or anything at all like that.

I tried quitting all the programs listed (Steam, DS4, etc), but still no luck. Would love to know how to solve this...

Just wanted to come here to give a fix. I had same problem and couldn't solve it this way. Light wouldn't stay on no matter what. I tried other way which is much more complex (you will have to overwrite your bluetooth files).
It took me a long while to get it working, because there is much to do, but IT WORKS!

Here's the link:

If you have problems, just browse that thread.
Hello Goes to:
And all I get is a big .rar file. I unzip it, and it's just the files themselves. No installation prompts or anything.

Also, I get error messages on the 'delete BTH and BTHENUM' parts: no permissions, just "Cannot delete: error while deleting".
When I tried to connect my DS4 through Bluetooth for the first time I referenced the first post. I didn't had to mess with the registry then. Everything worked out fine.

But when I did a fresh install on my computer, the Bluetooth didn't worked. I tried to do everything in that first post. Nothing. The DS4 just wouldn't stay on. I thought I had to do everything from the start, when I realized the step to remove the Bluetooth dongle from the Device Manager.

This is really simple, it worked for me somehow: just remove any Human Interface Device from there with the DS4 disconnected and turned off.
Then try to pair your DS4. It seems you can't connect the DS4 through a USB cable before trying to pair through Bluetooth. It must install the wrong drivers or something. Such a simple solution!!!

I disconnected my mouse doing this but just unplug/plug or use tab and arrow keys to the Scan Hardware button.

Enjoy and spread the good news. Smile
Thank you for the guide.

After leaving my ds4 on all night and let the battery drain, it stopped pairing with my pc.  It would try to connect and immediately disconnects.  I spent 4+ hours trying to find a fix.

I found you guide, followed it step by step, and now it's working again.
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go

Users browsing this thread: 1 Guest(s)