[BUG REPORT] Final Fantasy X Reversed Targeting
System Info:
Processor: Intel Core i7-4700MQ CPU @2.40GHz 2.40GHz
Memory: 16.0 GB
OS: Windows 7 (x64)
PCSX2 ver. 1.2.1

Looked all over the boards and cannot find mention of this bug. Note, it is NOT the backwards bosses; graphics are fine, excellent, in fact. The problem, starting with the very first fight, is that targeting is reversed. The targeting reticle will be on an enemy, the enemy's name will be displayed, (Sin Scale A, etc), but when I confirm the attack, the character attacks a member of my own party instead (in this case, Tidus, but I suspect it is whoever is in the first party slot)! Once Tidus goes down, the glitch continues, only now Auron starts attacking himself. If I instead target a member of my own party with the attack, the attack is executed against the enemy corresponding to their party slot (targeting Tidus attacks the monster in slot A, targetting Auron attacks the monster in slot B).

Auron's overdrive worked normally, but I have yet to try an overdrive that targets a single fiend; not sure if that will be affected by the glitch or not.

Please advise, as this glitch, while not exactly game-breaking, is very annoying! I have already tried adjusting some settings that supposedly work for the backwards bosses glitch (setting Clamping Mode to highest, Rounding Mode to pretty much anything except the default) to no avail.

Many thanks to anyone who can help me with this issue.

UPDATE: Just confirmed that Tidus' overdrive targetting single fiend works fine; targetting problem seems to only affect Attack command. Also, discovered an (almost certainly related) glitch involving choosing commands: whatever I select, I get the one above it (not including Attack). If I select Attack, it attacks with the targeting glitch mentioned above. If I select Skill, it also registers as a regular attack (still with the glitch). If I select Item with Auron, it opens his skill menu; if I select it with Tidus, who does not yet have any skills, it defaults to Attack. I cannot seem to access items in battle at all. Now it may be into the game-wrecking territory!

Sponsored links

I cannot reproduce.

You haven't changed your rounding/clamping modes have you?
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD
I was literally just about to post another update. After taking a bit of time away to think, I got a hunch and tried it with the keyboard instead of the XBox360 controller I had been using. Problem solved. Now I just have to borrow another one to see if it is my controller or Lilypad that was causing all the fuss.

(And yes, I tried pretty much every rounding/clamping mode, tweaking/turning off Speedhacks, and messing changing the render to different settings before I even made this post.)

Anyhow, mods please feel free to move this thread to a more appropriate board (if there is one for controller issues), or just delete it. Thank you, Blyss, for taking the time to look into the matter.

Happy Gaming, all!
since, this issue wasn't there in testing with the Keyboard, It's not probably a Lilypad Issue. For the sake of verifying it, could you also try it with any other controller and test it. Thanks Smile
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
I would guess you mapped one controller button to two ps2/pcsx2 controls. In your example probably A->X and A->Up. Everytime you click A he moves the pointer one up (to the opposite target site or next menu entry) and than validates what you intent to do.
Tried with another controller, and everything is working beautifully. And no, everything was mapped correctly, the old controller just had wires crossed or something. Thanks again, everyone.

Users browsing this thread: 1 Guest(s)