Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[BUG Report] Gamepad rumble does not reset after load state (Ridge Racer V)
#1
# PCSX2 version: v1.7.0-dev-596-g319287dbe
# Settings: default, gamepad rumble enabled

# Description:
Playing Ridge Racer V with a gamepad and rumble enabled, the rumble function works perfectly while racing but everytime I load a save state the rumbling remains active.

# How to reproduce this:
Make a save state just before starting a race; then start the race and play until you feel the rumble activation; at this point load the previous save state and notice the rumbling effect is still active from the previous session.

It's a little bit annoying but a minor bug, however, hope it can help!
Reply

Sponsored links

#2
I wouldn't consider it as a "bug" since it involves savestates.
Do you get the same problem with stable version ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(11-25-2020, 02:17 PM)jesalvein Wrote: I wouldn't consider it as a "bug" since it involves savestates.
Do you get the same problem with stable version ?

I haven't tested it yet on the stable version.

Update: I think it is a general issue because it happen also while playing Sylpheed.
Reply
#4
yeah, it's quite normal, that's how savestates are made.
it basically takes a an instant snapshot of the whole emu memory.

Honestly, i don't think it's a bug. it's just how savestates are made
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
ok, probably it is like you say, but in this specific case i think the rumble effect should be reset because the previous state at which I'm returning does not have/need a gamepad rumble functionality.

To be more clear, take Sylpheed for example:
Im playing the game and suddendly my ship is destroyed, the gamepad rumble activates but in the meanwhile I decide to quick load the previous save state which is the start-stage menu interface in which there should be no rumbling (it's a simple menu). Instead, what it happens (at least in my case) is that the gamepad rumble effect is still active in the menu screen (at full-power, 'cause it was associated with the ship explosion), and it keep going until I restart the stage again.
Reply
#6
Could you try olde builds like 1.4.0 and even 1.2.1 ? Just to see...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
Issue exists on github, not a game specific bug.
Reply




Users browsing this thread: 3 Guest(s)