Background texture's black borders
#1
Photo 
Hello,

I am playing Super Robot Taisen Gaiden. As you can see in the next image, I have experienced black borders in several background elements like the clouds or the buildings. I have tried changing every option in the settings and the issue only dissapears when I use software mode in the graphics settings. However, in the software mode, resolution is fixed to 1024x1024, lowering the quality of the game. So my questions are:

1)Is there any way to solve the issue in hardware mode, regardless if is with Direct3D or OpenGL?
2)Is there any way to upscale the resolution in software mode to, at least, HD?

Just one of them will solve my issue.

Thanks!

https://photos.app.goo.gl/pXhwZnhZsjoS8YRa7
Reply

Sponsored links

#2
For these 2D games it is better not to use any special scaling settings. Have you tried setting „Texture Filtering” to „Nearest”? This should solve the problem - if not, you could make a screenshot of your graphics settings and paste it here. Smile
Reply
#3
(03-25-2023, 04:26 PM)Khi Wrote: For these 2D games it is better not to use any special scaling settings. Have you tried setting „Texture Filtering” to „Nearest”? This should solve the problem - if not, you could make a screenshot of your graphics settings and paste it here. Smile

Yeah, I have tried nearest, Bilinear Forced and every possible option in the settings without success Sad

No problem sharing my graphic settings. I just change this from Hardware to Software to play this game

https://photos.app.goo.gl/YY78BamwCvNzsbY86

Thanks!
Reply
#4
Have you also tried testing the latest PCSX2 nightly releases with this game? Give it a try and if that does not help, you can create a single frame GS dump as last thing and put it here as an .zip compressed file attachment so that all people who do not have the game can do a self-test. Just press Shift + F8 during the issue and then you can find the created file in the PCSX2 directory. Do not worry, the problem will surely be analyzed quickly then. Smile
Reply
#5
Great!

Here is the .gs file. I hope it helps:

https://mega.nz/file/0lExADZS#CCszJ8dfSR...QcE32N_gdA
Reply
#6
Okay, i also experimented a bit and was able to fix the issue „optimally” (see the picture in the attachment). I have also attached the per-game setting i used for this so you can drag this .ini file in the .zip file into the „gamesettings” folder if you are now using the newest PCSX2 nightly releases (important). The most important settings was the „Half Pixel Offset” setting which had to be changed. You will of course have to test the game yourself to see if these settings remain optimal. For the most accurate result, you would need to set the internal resolution to native, but you can use any scaling with these settings - i have left it scaled. The „Anisotropic Filtering” option can make some textures look blurry, so i set this option to off. I also changed other settings that seem to be important for this game. Please test these settings and tell what you think, because i am just a normal user and not a developer - maybe someone else will get back to this thread who knows it better. Good luck! Smile


Attached Files Thumbnail(s)
   

.zip   SLPS-25836_B0E44B93.zip (Size: 1,49 KB / Downloads: 51)
Reply
#7
Issue solved!!! Thanks you very much. I love the new QT interface. It's amazing!
Reply
#8
Glad i could help somehow! Laugh
Reply




Users browsing this thread: 3 Guest(s)