Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Berserk PS2 randomly crashes on PCSX2 1.6.0
#1
Hello everyone I recently decided to play Berserk: Millennium Falcon Hen Seima Senki no Shou PS2 but I am having a problem with this game

The emulator shuts itself down randomly without an error message while I play ... I'm not sure what to do in order to fix the problem?

Here is my config if it helps:
Windows 10
RTX 3080
I7 10700KF
32go RAM

I use the official version of PCSX2 1.6.0, for this game I had to check "Switch to GSdx software rendering when a FMV plays" in the patches in order to have the subtitles during the cutscenes
I also activated the MTVU speedhack because I read that it was a good option for processors with more than 3 cores

Then I activated a patch for the 60FPS and the widescreen, at the first crash, I deactivated this patch but the crash is still happening

I am playing with Direct3D 11, should I use OPENGL?
Do you have any idea where this could come from?

I didn't see anything special on the game wiki, I applied the changes correctly but no one mentions a random crash ...

thank you and have a good day
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Hello

Small feedback after a 40min session, I didn't have a crash when disabling mtvu speedhack

I'm not going to say it's 100% resolved but it seems on the right track ...
However, with this option and my processor it is supposed to work right? weird .. as long as the problem is solved, all the better
Reply
#4
if MTVU was crashing you could consider getting a 1.7 build from the development downloads as we made some big fixes to MTVU.

Of course if the game runs fast enough without it, you don't need it, then you're fine to continue on 1.6
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
I was able to play 1 hour without problems again, I think my problem is solved

MTVU is the culprit on version 1.6

The game runs well without, I don't think I will test on a 1.7 version but thank you for the precision, I will try it if I play another game
Reply




Users browsing this thread: 1 Guest(s)