Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Best PCSX2 settings for my PC?
#1
Hey everyone, I recently upgraded my computer and I was wondering what the best PCSX2 settings for it would be.

My specs are as follows:
CPU: Intel Core i5 6600K @ 3.50 GHz
GPU: GTX 970
RAM: 16 GB

The game I'm trying to run, along many others, is God of War, but after messing around with the settings for a bit, I still couldn't get it to run without slowdowns on Hardware mode with Direct3D 11. When I press F9 to change it to Software mode, however, the game runs smoothly as expected. Shouldn't my PC be able to handle games at high settings?
I can provide screenshots of my current configurations, but maybe they should be set up again from scratch since I altered them a bit...

I appreciate any help you can give me. Thanks in advance!

EDIT: I'm using PCSX2 1.4.0, forgot to mention that.
Reply

Sponsored links

#2
how much ram do you have on your GTX 970? and is it a Ti or not?
Reply
#3
(01-27-2017, 10:31 PM)Saiki Wrote: how much ram do you have on your GTX 970? and is it a Ti or not?

....There is no 970ti and they only came in 4GB variants where only 3.5GB was useful.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#4
it was the 980.. I was close.. and you think everyone keeps up with EVERY bit of hardware on the market?
Reply
#5
(01-27-2017, 11:03 PM)Saiki Wrote: it was the 980.. I was close.. and you think everyone keeps up with EVERY bit of hardware on the market?

It is in fact 4 GB as mentioned above
Reply
#6
Not that any of that matters. Even a 2GB version would be more than good enough.

Please post any non-default settings you're using.
Reply
#7
Here are all of my settings, since I don't know which ones were changed (I've messed with them before). Please let me know if I forgot any!


Attached Files Thumbnail(s)
                               
Reply
#8
A few suggestions:

Set EE Cyclerate speedhack slider back to the middle(0), or one to the left instead.

In the GSdx settings set CRC Hack Level back to "Full". You also enabled HW hacks, but didn't post those settings. There are some options there that could cause slowdown as well.
Reply
#9
(01-28-2017, 03:12 PM)FlatOut Wrote: A few suggestions:

Set EE Cyclerate speedhack slider back to the middle(0), or one to the left instead.

In the GSdx settings set CRC Hack Level back to "Full".  You also enabled HW hacks, but didn't post those settings. There are some options there that could cause slowdown as well.

Ok! I did what you said and my settings are attached below.

EDIT:
I just checked and the slowdown is gone, thanks! Any way I could improve my graphical quality even further? Or would it cause slowdowns with my current hardware?


Attached Files Thumbnail(s)
   
Reply
#10
You can switch to using the OpenGL (Hardware) renderer and enable "Hardware Depth".

You will lose the MSAA though(note: MSAA also has a noticeable impact on performance).
Reply




Users browsing this thread: 2 Guest(s)