Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Beyond Good And Evil slowdown and flickering on software
#1
In hardware rendering the game is virtually unplayable as a lot of textures just load in as black smudges, I'm guessing nobody ever got to the bottom of that as the compat list does say to use software mode. So, with that in mind...

I'm having trouble with flickering and slowdown on BGaE. The flickering mostly happens on the skyboxes, but does also rear its head elsewhere. Good thing I'm not prone to seizures, because it's actually quite bad.

The second issue is slow down. Especially during combat, the game drops to around 50%, but - like the flickering - it's not restricted to just that area. It occurs in many areas. 

I'm not sure if anyone ever found some settings that work great with this game or not, but I'm hopeful!

I'm using the latest version of PCSX2 stable (1.4.0), and these are the settings I'm using. Not 100% sure what you need to know or what's relevant...

GS: GSdx 20160105132032 1.0.0
Direct 3D 11 Software
Edge AA, 4 threads, Mipmapping. TV shader: none. 

Audio: SPU2. Module: 1 - XAudio 2. Sync: Timestretch (I'm guessing this is why during slowdown everyone sounds like they're talking in slow mo...)

EE/IOP: Recompiler/Recompiler. EE cache disabled. Round mode: chop/zero, clamp: full
VUs: VU0 & VU1: microVU Recompiler. Round mode: chop/zero, clamp: normal
GS: Disable framelimiting disabled (so.. framelimiting enabled?), frameskipping disabled
Speedhacks enabled: EE Cyclerate 0, VU cycle stealing 0. 
Other hacks: INTC Spin detection, wait loop detection
Micro VU hacks: mVU flag hack
Manual gamefixes: disabled

System is i7 4790k, Radeon R9 200 series
Reply

Sponsored links

#2
using latest git + trying OGL renderer may be of a help.
i think this game hasn't been tested with ogl renderer yet
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(06-16-2018, 05:44 PM)jesalvein Wrote: using latest git + trying OGL renderer may be of a help.
i think this game hasn't been tested with ogl renderer yet

That definitely seems to have fixed the flickering. I'll report back on the slowdown.
Reply
#4
(06-16-2018, 05:59 PM)chrisjfinlay Wrote: That definitely seems to have fixed the flickering. I'll report back on the slowdown.

Slowdown has improved for sure but it does still drop to around 80% during the first boss fight. Definitely much more playable, though.
Reply
#5
since you have an AMD graphics card, you might be better off with the Direct3D11 renderer
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
(06-16-2018, 06:08 PM)refraction Wrote: since you have an AMD graphics card, you might be better off with the Direct3D11 renderer

D3D 11 hardware resulted in the same black textures. Software much the same as OGL in terms of slowdown, perhaps actually a little worse in places. I left it on default settings
Reply
#7
did you try latest git ?
because D3D11 renderer improved too (not as much as ogl, of course)
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
Yep, latest git, 62b7097
Reply
#9
Try enabling "Memory Wraping" in gsdx hacks.
Reply
#10
(06-16-2018, 06:33 PM)kozarovv Wrote: Try enabling "Memory Wraping" in gsdx hacks.

No good, full of black textures still. Think hardware mode is a general no-go for this game tbh!
Reply




Users browsing this thread: 1 Guest(s)