Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Biohazard Outbreak OpenGL poor performance with Blending Unit Accuracy
#1
Hello, I'm actually a moderator for the Resident Evil/Biohazard Outbreak private server at obsrv.org and have just recently gotten into PS2 emulation.
I'm kind of an accuracy whore so I prefer to use OpenGL since it plays nicer especially on Outbreak File 2 with the reflection shadows on Wild Things, but the effect is only emulated correctly with Blending Unit accuracy. Outbreak File 1 slows to a about 82% speed when I leave the setting on basic and File 2 will actually run full speed until I reach specific open areas where it'll dip in performance. I can't even imagine why this is happening since I tried Silent Hill 3 earlier and managed to play the beginning mall segment with Blending set to Full with no slowdown.

The EE never reaches more than 14% when the slowdown occurs and the GS is at 8%. I'm playing the latest dev version.

Here are my specs. I'm running the latest Windows 10. If it matters, if I change to software mode, the games run fullspeed no matter what, even for OpenGL. And as far as I'm aware, I was always under the impression that emulation was CPU intensive, so at first I thought the issue was my CPU. But then why would HW have slowdown, but SW be fullspeed?
Reply

Sponsored links

#2
Blending Unit Accuracy does not scale across every game the same way. It should only be set to the setting required to emulate everything you want correctly (shadows, ect.) otherwise you will have to lower the setting to gain performance back.

Many games technically "need" Ultra accuracy to have the smoothest picture but it is not feasible for most of them. It depends on how the effects are implemented as well, so can still make use of blending and run full speed with Ultra.
Reply
#3
Is there any other way to gain performance? I have it set to basic and it's giving me trouble. Or should I just rely on the software renderer.
Reply
#4
Would depend on your PC's specs
Reply
#5
My specs are linked in the OP. I tried overclocking to 3.8 Ghz but I got the same exact percentages for EE and GS, so I'm going to go out on a limb and say it's the 1080ti?
Reply
#6
1. What are the other settings you are running in the graphics plugin?

2. What is your GPU's utilization in something like afterburner or other monitoring software when the slowdowns occur.

3. Have you gone in to Nvidia's control panel and set PCSX2 to prefer maximum performance? (Nvidia does not always see emulators as workloads it needs to allow it's GPUs to actually clock up for.)
Reply
#7
Every other setting is left at default. I set the resolution to native just to check and get the same results.

Afterburner confirms my suspicions. It appears that my GPU usage jumps to 99% when using blending accuracy (basic) on Outbreak File 1. Turning off blending accuracy drops my GPU usage to 3-13%. Anyway to fix this? It seems like an extreme change. I have PCSX2 set to maximum performance in the Nvidia control panel and on the global setting.
Reply
#8
Can you upload a gs dump of the issue?
https://forums.pcsx2.net/Thread-How-to-c...er-GS-dump
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 10 Pro 64bit
Reply
#9
Here you go.
EDIT: Ah, I probably should have renamed it. I probably also should have read that post all the way.


Attached Files
.xz   gsdx_20190928231640.gs.xz (Size: 1,63 MB / Downloads: 83)
Reply




Users browsing this thread: 1 Guest(s)