Bios or Iso problem

This is probably a very simple problem to fix (hopefully!) and I'm just being stupid, but I'm new to PCSX2 and can't get the program working.
I have downloaded Final Fantasy 12 (which I also own on disk) and extracted it to .iso format.
I've also downloaded the PCSX2 program (1.2.1) and fully installed this along with directX.
However when I open the program it seems to be unable to use the .iso file and wants a .bios instead?
When I run the PCSX2 program I select to import the PCSX2 settings (apparently in the folder). It then enumerates the plugins and comes up with the list of GS, PAD, SPU2 and CDVD etc... If I choose 'next' from here, it then wants a BIOS search path but even when I select the folder my .iso file is in, it doesn't recognise it.
I've also tried changing CDVD to the 'Linuz iso' option with no success.

What do I need to do to fix this? My actual PS2 disk is at home at the moment so I can't access it right now!


Sponsored links

You need to dump the bios from your ps2 console
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
What does that mean doing?
My PS2 is also at home (I'm currently at uni) along with the disk so do I actually need that in order to be able to access the file?
Yes, you actually need to be at your console to dump the BIOS
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Delete that downloaded crap and remake everything (bios/iso) from original materials. You'll avoid lots of problems by doing so
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)