Bios won't show up in first config
So I've dumped my bios. I start pcsx 0.9.7. The first time config window comes up. It's smooth sailing all towards the Bios selection window, the last one. This is where the ***** hits the fan.

It makes, if left default, a directory in your My Docs folder. In here I made a folder called Bios, which I placed all my Bios files into. I then hit the Refresh button. Nada. Okay, so I think it doesn't know where this folder is, which is kind of normal. So I hit the Open in Explorer button, with the "default" still checked on. It seems that it DID automatically find the Bios folder and all the Bios files ARE inside. Strange. I quit, and run the program as Admin. Doesn't work either. I decide to make a custom folder, in the pcsx program files folder. Bios still won't show up. Are my BIOS files corrupt? It all seemed fine, but I start up my slow as ***** pc. Install again, everything goes fine, past in BIOS files. Holy *****, the BIOS files show up in the First time config. It'll even fire up a game with 1FPS. So the BIOS is fine.

If, after this wall of text, any of you are still reading, could you tell me what I'm doing wrong?

Also, Slow pc = XP, Fast one that can't find BIOS: Win 7.

Sponsored links

Begin with telling us your machine specs, like CPU model, video card used, and screenshots of the plugin/Bios selector window.

as much information you are able to provide since if you were able to browse the bios location it would show up at the first configuration.

About that too low FPS, well, only providing us with the asked above information will be possible to give a meaningful answer. Please tell us the game's name too, it may be one actually yet unplayable...
Imagination is where we are truly real
The Low FPS doesn't matter because the machine is 4 years old. The machine it SHOULD work on doesn't go beyond the config, and the specs for that are below. Maybe it wasn't clear that I used a second PC to test the BIOS, which is why it has such slow FPS..


OS: Win 7
CPU: Core2Duo T9400 @ 2.6GHz.
6 GB Ram
ATI 4850

Here are three pictures of the three windows of the First-Time Config. All kept default:

As you can see, there are files, that DO show up on the other slow PC, and they DO work. They will however NOT showup on the fast PC. Admin rights, custom folders, doesn't work. I've tried switching the plugins but that shouldn't be an issue for the BIOS, and ofcourse it didn't do a thing.

If there's something else you'd like to know, just ask.
From previous experiences with UAC, Vista and seven "security features" are the dumbest thing seen in many years....

As a rule, a sacred rule, avoid installing anything under the "Program Files" folder (the same for it's x86 kin). Just by uninstalling it from that less than blessed folder and installing somewhere else may solve all your issues at once. THIS applies for any game, this advice is the most seen on sites that deal with moddable games in general (they are most vulnerable because the user's content and utilities).

All kind of strange things happens in those "protected folders", files that got moved to hidden areas, access failure... too much different issues to ever list them all.
Imagination is where we are truly real
UAC isn't turned on though. I don't really care for that. Still, I've rechecked everything and it was all turned off. Even googled it, to make sure. It was off.

As for your "Program Files is Satan". I've uninstalled, restarted, and reinstalled on the Desktop. No cigar. I unstinalled, restarted and installed on C:\. No cigar. I've unstalled, restarted and installed in My Documents. No cigar. I then uninstalled, restarted and installed it on my secondary drive. No cigar.

Right now, I still cannot choose my Bios.
So, excuse me for not using my own Bios and breaking the rules, I downloaded several Bios files, and they also do not show up.
This makes it look like it's not my dumped Bios' fault, since it works on another PC.

wat do?
1) put it into my documents folder
2) run as administrator
3)be sure the bios files are inside the bios folder that is located in pcsx2 folder
4)be sure this folder is selected and there is no other folder "before" the bios files.
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
1. I have tried doing that, see 3d post, and that had no effect.
2. I have tried running it as Administrator before, this didn't help. I have tried to run it as Admin for every try, as normal user, and as Admin. It did not work. Also when it was in the My Docs folder.
3. I have put the Bios folder in several places. In the installed folder, standard folder for PCSX. I have put it in a custom place. Neither worked. Not regular not as Admin.
4. Yes, it's PCSX > Bios > Files. No subfolders. It would be illogical to have subfolders inside this folder. This was never the case.


Also, to be clear, I've tried both the stable 0.9.6 version and the public beta 0.9.7 r3119, but is installed as r3113. Yes I did read the announcement about it. There is no BIOS in either.
On the paths, why is there that symbol instead of / ? That looks horribly wrong and have no idea how or why it is like that, but that should be the problem.
[Image: newsig.jpg]
This is because the machine is localised as Japanese. As this is a rare problem that programs may not work, I have already adjusted this to English. It failed again.

Yesterday my friend came by and brought his laptop. He also has a machine localised as Japanese(we're both weeaboo Visual Novel readers) and pcsx 0.9.7 and 0.9.6 could both find the Bios files and play a game. We then changed the localisation to English, and it kept working. This should not matter, since all it does is add support for programs with Japanese characters.

As for my friends laptop:

Win 7
i7 720QM
Ati HD5870
Asus G73JH

With my friends' laptop, I have repeated all steps, different instalation locations, admin rights and it all kept working.
I just want to bump this for a fix.
Attention for these sort of topics fade quickly.
Excuse me for doing this.

Users browsing this thread: 1 Guest(s)