Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Black frame every 40s/50s or so
#1
Sad 
Hi, I have been looking all around the forum and google to see if anyone else has experienced this but couldn't find anything.

What happens is that everything works flawless, 100% speed, no artefacts, everything looks gorgeous but every now and then a black screen for one frame comes up. The game doesn't slow or stops, it is just a render black frame every minute or so and it is really annoying as I can't play games as I am constantly looking for that one black frame, no matter what game I play. It happens in every game! Wacko

I am using pcsx2 1.5.0 dev2793, tried everything, ogl, dx11, soft render, every single option, on and off that I could think off, but nothing seems to fix it. Updated Nvidia drivers. Toggle Nvidia presets. I really don't get it. I've got every single emulator out there, there all works just fine (as well as they can emulate each console, of course) none do that black frame screen. I don't think it is my graphics card's (GTX 960) fault. I've tried NTSC games, Pal games, USA bios, EU bios, you name it, I've probably tried it. Really annoying. I am trying to finish Rogue Galaxy after my ps2 died on me last month Sad

Anyone experienced this issue? Is there anything I can try to fix that annoying black screen. It even happens when slowing down to 10% the base framerate adjustment! Skip frames, doesn't help either.

Thanks guys
Reply

Sponsored links

#2
Can you post a video of what's happening?
Reply
#3
(12-22-2018, 06:53 PM)CK1 Wrote: Can you post a video of what's happening?

Yes, sure, I had to capture the whole screen to be able to see it, as getting only the pcsx2 windows somehow that black frame didn't got captured Huh Around second 22 you can see it.

https://www.dropbox.com/s/qrfhwdqi5ofdzl....46.05.mp4

Options for the capture:
   
   
   

Everything is default. I've tried everything, every single option, combination that I could think of. Same results, no matter what, every now and then, black frame.

Specs of my pc:

   
   
   
   
   

Thanks again for looking into this issue and helping me out, let me know if you need or want any more info about my setup.
Reply
#4
No one? No?!  Sad
Reply
#5
is this something you only get with pcsx2 ?
because it doesn't look like a pcsx2 bug to me, more of a GPU drivers one
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
(12-26-2018, 12:32 PM)jesalvein Wrote: is this something you only get with pcsx2 ?
because it doesn't look like a pcsx2 bug to me, more of a GPU drivers one

Yes, only with pcsx2, I've got cemu/citra/rpcs3 only to mention the ones that use the gpu the most and I don't get any black frame. I will try to change drivers again and see if that fixes it.
Reply
#7
Try with some drivers below v400
If you really tied all possible settings in pcsx2(are you using frame skipping or anything non default(enable the preset and set it to two))the problem is most likely drivers or something external(not pcsx2)...nvidia experience\ansel maybe.
Reply
#8
Running OpenGL or DirectX btw? try switching from hardware to software mode (Press F9).
Reply
#9
Thanks a lot guys, I had to load up the driver 392.24 for that black frame to be gone. With the latest drivers, as today 417.35, the black frame was gone but there was few white lines on the right of the screen that some times flickered. No go, back to old good drivers and happiness. I finally be able to finish this amazing game. The downgrade of driver even improved performances in Assassin's Creed Odyssey, few frames, from 55 fps to 58 fps in average using old 392.24!!! Looks like they want me to change my graphics card! I won't upgrade drivers until I buy a new card in two years!

Anyway, thanks again guys.
Reply




Users browsing this thread: 1 Guest(s)