Black screen while playing Final Fantasy X-2
I'm simply devastated. After few months of wonderful time with pcsx2 such cruel thing happens.
The thing is about Final Fantasy X-2, quite nice game, which I was dreaming of since playing Final Fantasy X. I was so surprised when problem occured, because I already spent some time (35 hours....) enjoying FFX-2.
Besides of general error, I cannot complain - gameplay FPS about 65-75 (yep, I like some things fast), no weird shaking, sounds, missing geometry or such things.
Back to the topic - problem shows up in the middle of a game (54%...). Don't know if someone who hasn't play FFX-2 understands me, but after entering Kilika Temple, in Chapter 3, after very first battle with fiend, not even boss, but after short cutscene, game crushes. I mean, after battle there is summary with exp as always, but after pressing 'x' to confirm it, black screen shows up. Music is still playing, and frames are moving, but I can't see a thing.
Now, cutting of my gibbering of dying player, some tech details.

My computer info:
64-bit Vista Buissnes.
Intel Core 2 Duo E7200 2.53GHz,

I use beta version 1474 of pcsx, but I know that you do not support betas, so I tried official one, 0.9.6 with same result.
My pluigins:
I tried turning on and off speedhacks, with no effect.

Is there any hope for me? Ah, I'm playing US version of game, if this info is needed.

Sponsored links

Does it show any specific error in the pcsx2 condole eindow when the crash happens?

Do you have any speedhacks enabled? Try disabling them if so. Try changing the "config > advanced" options.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
OK first use the same pad plugin for both controllers. Using different ones causes problems.
Second try using another SPU2 plugin like SPU2-X or PeoPs SPU2
[Image: newsig.jpg]
Thank You for answer. Basically, I don't use speedhacks, because even without them game is working just wonderful and fast.
I tried other sound plugins, like Pete's, Gigaherz or Zero (no effect).
It's how game looks like just before crash (or whatever disaster it is) :
(beware! bigger resolution)
And after pressing 'x':
although nothing is visible, music is still playing, no matter what.
Hmm I see you have a patch loaded,try disabling it.
If that fails try going in advanced and setting round modes to negative (both)
[Image: newsig.jpg]
It's working! Working! Working! I'm sorry, but I'm so excited! I tried even different graphic plugins.
Well, I'm not sure, what helped (I'm gonna check in a minute) but I cut off patches from patch folder (I'm newbie so I don't know how to disable them) and turned off every single box in advanced menu.
I'm sooo grateful! Wink
You just go to Misc->Enable patches and uncheck it Tongue
[Image: newsig.jpg]
Thanks again! It seems like it was just a patch problem, because I turned on round mode and game is still working (goodbye black screen!)
Problem solved. Forever Yours! (as long as it's about pcsx...^ ^). Have a VERY nice day, You deserve it.
Okay this bump is ridiculously old but I just got this problem and saw this thread on google. So, I'm encountering the same problem, with the 0.97 r3878.

Tried disabling patches, swtchng the round values, changing spu2 plug-in, even tried changing the GS plug-ins but nothing's working.
Exactly what is the problem? Where are you having the problem? What does the log say?

Saying your problem is the same can be misleading, it's best to work from the start.
[Image: 2748844.png]

Users browsing this thread: 1 Guest(s)