Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Both PC and PCSX2 freeze
#1
I used to use OpenGL hardware renderer and it works fine, but the GPU usage exceeds 90% and it gets low fps for known instants in battle. That's the only problem I face when using OpenGL. I play Persona 4. Tried to change the renderer to Direct3D 11 Hardware and the problem solved, even the GPU usage went below 50%. But then I had another problem and it occurs only when using Direct3D 11 HW. The problem is that sometimes when I make it windowed to check anything else and I return to play, I double click the game to full screen mode but it freezes and the PC also. It does happen from time to time. At this moment I can't use my PC to open anything even ALT+CTRL+DEL page doesn't open and I am forced to restart my PC. No speed hacks used.
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Reply
#3
(01-07-2018, 12:17 AM)CK1 Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

AMD Ryzen 5 1600 Six-Core Processor, AMD Radeon RX 580 Series, 16GB RAM DDR4 single, Windows 10 Pro (x64)
PCSX2 1.4.0 
I tried using Direct3D 11 with default settings with no hacks involved but the problem still occurs. OpenGL solves the problem but its GPU usage is very high and has a minor problem in battle.
Persona 4 (ISO).
Reply
#4
Download the latest dev build and see if it's fixed in DX11: https://buildbot.orphis.net/pcsx2/

Generally, you can't run OpenGL well because they AMD drivers have problems with it. If the frame rate is acceptable to you, then you can stick with that.
Reply
#5
(01-07-2018, 02:55 AM)CK1 Wrote: Download the latest dev build and see if it's fixed in DX11: https://buildbot.orphis.net/pcsx2/

Generally, you can't run OpenGL well because they AMD drivers have problems with it. If the frame rate is acceptable to you, then you can stick with that.

I tried the latest one but didn't work. Direct3D 11 HW runs the game perfectly with 6x native and less than 50% gpu usage but I got this freezing problem with it.
Reply
#6
(01-07-2018, 02:55 AM)CK1 Wrote: Download the latest dev build and see if it's fixed in DX11: https://buildbot.orphis.net/pcsx2/

Generally, you can't run OpenGL well because they AMD drivers have problems with it. If the frame rate is acceptable to you, then you can stick with that.

I tried the latest one but didn't work. Direct3D 11 HW runs the game perfectly with 6x native and less than 50% gpu usage but I got this freezing problem with it.
Reply
#7
Hmm ok. Maybe try lowering your resolution to native and see if it still freezes. That could indicate a problem with your GPU.

Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
Reply
#8
(01-07-2018, 03:03 AM)CK1 Wrote: Hmm ok. Maybe try lowering your resolution to native and see if it still freezes. That could indicate a problem with your GPU.

Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.


Attached Files
.txt   emuLog.txt (Size: 1,72 KB / Downloads: 16)
Reply
#9
The log still indicates that you're using the old exe and plugins. Can you get a log from the newer build?

Make sure that you're using the 1.5.0 exe (with the dark blue background) and make sure that the plugins contain "2018" in the filenames - those are the newer ones.
Reply
#10
(01-07-2018, 03:09 AM)CK1 Wrote: The log still indicates that you're using the old exe and plugins. Can you get a log from the newer build?

Make sure that you're using the 1.5.0 exe (with the dark blue background) and make sure that the plugins contain "2018" in the filenames - those are the newer ones.

This log is from the latest version of the emulator posted on this site: https://buildbot.orphis.net/pcsx2/


Attached Files
.txt   emuLog.txt (Size: 1,73 KB / Downloads: 24)
Reply




Users browsing this thread: 1 Guest(s)