Browser/System configuration settings not applying
Hi all.

I am using the 1.7 AVX2 Build. I have been struggling with my 1400STR non-overclockable laptop trying to emulate PES 2013. So I went to the system configuration menu (boot no ISO), changed some settings and, voila, my game began to run at steady 60fps with battery. I checked hwinfo, OCCT, and coretemp. My cpu was only drawing 9-12w, no different from before change of settings. CPU speed was capped at its turbo speed.

To test further, Increased blending accuracy full, and it has no effect, cpu wattage only increased by 3w. Tried to increase the resolution to 4x-6x resolution, and my fps didn't tank. It only crippled when I turned off MTVU. Toggling on MTVU again returned my fps to a stable 100%. EE and VU cycle hacks were not used. Sadly, my battery was drained after an hour or so (35wh).

So today, I tried to do the same on the 1.60 build and the SSE4.x versions.
That's where the problem comes in.

When I changed the system configuration in one version, say, 1.60, the settings were immediately reflected in the other versions, and vice versa. After this happened, my system configuration settings are no longer applying, although they are intact when I I enter the sys configuration menu.

So how do I know the settings aren't applying? WIDESCREEN!
Since 1.60 I have never needed widescreen patches. I uncheck cheats and widescreen cheats. My GS window is at 16:9. 

Before now, in any verison of pcsx2, if I set the sys conf setting to 4:3 or FULL, the image is stretched. But if set to 16:9, it game is rendered in normal unstretched 16:9. I even compared this to a widescreen patch. Downloaded one, changed my system configuration (from no disc boot) to 4:3, set GS to 16:9, game is stretched as before. Enable cheats(copied the patch to the cheats folder) and the game corrects to an unstretched 16:9 exactly like the setting 16:9 from boot.

Now, without cheats/widescreen patches, the game doesn't render at 16:9 even if I set it in the BIOS SYSTEM CONFIGURATION. If this setting isn't applied, it is most likely the rest of the settings in the same menu aren't being applied.

Please how do I correct this? I have deleted every version, redownloaded, formatted memory cards, changed pcsx2 folders, and yet no change.

Also why did the settings in 1.60 affect that of 1.7? 
The 1.60 was in my documents folder, whilst the 1.7 was in my downloads folder. The memory cards directories was of course different?

Extra info. 
Power plan settings when the battery "worked with" the pcsx2 was 
max processor state: 100%
Min processor state:  1%
Cooling: passive

With plugged in, all settings are the same except for active cooling. Heck, I changed the min for battery and plugged in to 100%. Changed battery to active cooling, and AC to passive and vice versa, over a hundred times now.

My PC is AMD 3020e 1.20 ghz base, and 2.60 turbo. Can't be overclocked.


Sponsored links

IIRC to make the game loads the screen settings from the System Configuration, it must be booted with "Full Boot" method (So, you'll have to uncheck "Fast boot" option if there's one). Then again, it depends if the game indeed loads settings from there (only handful does).
[Image: cGzK8nC.gif]
(04-22-2022, 02:42 PM)BloodRaynare Wrote: IIRC to make the game loads the screen settings from the System Configuration, it must be booted with "Full Boot" method (So, you'll have to uncheck "Fast boot" option if there's one). Then again, it depends if the game indeed loads settings from there (only handful does).
Yeah, I have tried every setting on there in pcsx2.
I have tried full boot and fast boot.
As I said in the op, the game has always used the settings from the bios, e.g. the 16:9 without widescreen patches or cheats enabled, always gave a correct unstretched 16:9. Downloading widescreen patches and using them with 4:3 in System config (and 16:9 in gs windows) gave no difference i.e unstretched 3D and stretched 2D elements.
If the 16:9/4:3 settings stopped applying in the same game overnight, I don't think any other setting from System config is being applied

 Also ignore any other settings. I did not touch any other settings in PCSX2 other changing a few settings in the NO DISC system config. 

This problem only started after I tried to do the same on the 1.60 version, only to find that my system config settings were now broken. Changing the NO DISC system config on one version automatically changes the settings on the other versions( tested dozens of combination of settings), and that the settings no longer apply to the game, as seen with the 16:9/4:3/FULL settings now working as 4:3 regardless of chosen option.

I am not asking for widescreen patch here. Just want my settings from BIOS SYSTEM CONFIGURATION To apply ingame. 16:9 vs 4:3 is just my test to see if settings are applied.

I have tried different PS2 BIOS, NTSC, PAL, europe, japan, NA etc.

Using a BIOS file with PCSX2 which you have downloaded from the internet or from a PS2 console you do not own is illegal. You must own the console the BIOS file came from (even if it's broken) to be legal.

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)