Bug ?
#1
Recently i'm experiecing some random crashes when I play games, I checked the log and I got a spam of this: 

Possible incorrect Q value used in COP2. If the game is broken, please report to https://githubcom/pcsx2/pcsx2.
337af0  00000000 nop
337af4  00000000 nop
337af8 *4A6D03BC vdiv Q, vf00w, vf13x
337afc  48A22800 qmtc2 v0, vf05
337b00  4BE12BAC vsub.xyzw vf14, vf05, vf01
337b04  4BCC73EA vmul.xyz vf15, vf14, vf12
337b08  4A8F7BC0 vaddx.y vf15, vf15, vf15x
337b0c  4A8F7BC2 vaddz.y vf15, vf15, vf15z
337b10 =4A807BDC vmulq.y vf15,vf15,Q
337b14  48227800 qmfc2 v0, vf15
337b18  7FA20000 sq v0, 0x  0(sp)
337b1c  44801800 mtc1 zero, f03
337b20  C7A00004 lwc1 f00, 0x  4(sp)
337b24  46030034 c.lt.s f00, f03
337b28  00000000 nop
337b2c  4501001B bc1t ->$0x00337B9C
337b30  7FA20010 sq v0, 0x  10(sp)

I'm using the latest Nightly build ( 1.7.3337 )


Attached Files
.txt   emuLog.txt (Size: 14,64 KB / Downloads: 51)
Reply

Sponsored links

#2
do you get the same when goinf back to older builds ? or even stable 1.6 ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#3
(09-25-2022, 10:35 PM)jesalvein Wrote: do you get the same when goinf back to older builds ? or even stable 1.6 ?

Yeah, just tested the Stable 1.6 and didn't get this message. I was thinking if it could be my memory cards, but no... I created new ones. Well, I played a little and didn't get any crash, don't know what was wrong with the other version.
Thank you.
Reply
#4
Could be worth updating your GPU drivers
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#5
(09-25-2022, 11:17 PM)jesalvein Wrote: Could be worth updating your GPU drivers

I have some news.
My drivers are up-to-date.
I was going on the versions that updates the pad controller database and I discovered that if I play on the specific nightly build 1.7.2364 ( description: pad-windows/unix: Update to latest controller database ), any other version before this I don't get that message. I really don't know why this happens, maybe something related to drivers, I really don't have any idea.
Just to clarify, I play with a original PS2 Controller, connected to a USB adapter (I will attach a image).


Attached Files Thumbnail(s)
   
Reply
#6
Okay, a little more tests I figured out that when I update for 1.7.2361 I get that message, this was a build that on the description says: ''COP2: Move COP2 timing messages to release builds.'' . Any version after this, I get that message... any version before this I don't get.
I really really don't know why this happen.
Reply
#7
ignore it, it's a false positive.
[Image: ref_sig_anim.gif?ex=65f40671&is=65e19171...551a681a&=]

Reply
#8
(09-27-2022, 02:34 AM)refraction Wrote: ignore it, it's a false positive.

Just got a suddenly crash, same game (The Warriors NTSC), same message.
Reply
#9
the COP2 messages are nothing to do with it.

What is the actual crash saying? or is it just closing the emulator?
[Image: ref_sig_anim.gif?ex=65f40671&is=65e19171...551a681a&=]

Reply
#10
(10-01-2022, 07:34 PM)refraction Wrote: the COP2 messages are nothing to do with it.

What is the actual crash saying? or is it just closing the emulator?

Its only that message, there's no ''error'' ''crash'' on the log.
Just this:
padman: *** VBLANK OVERLAP ***
Patching 319 SFXs address 217104 -> 1825776
We allocated 8192 bytes from IOP memory
Fr:  27, FPS: 28.3, Rate: 341964, Video: 25%, Audio 7%, Blit: 58%, IO: 0%, Filled: 95%
Fr:  59, FPS: 28.0, Rate: 488520, Video: 42%, Audio 4%, Blit: 52%, IO: 0%, Filled: 94%
Fr:  91, FPS: 29.9, Rate: 422184, Video: 37%, Audio 4%, Blit: 57%, IO: 0%, Filled: 93%
Fr:  123, FPS: 29.9, Rate: 430274, Video: 38%, Audio 4%, Blit: 56%, IO: 0%, Filled: 94%
[GameDB] Searching for 'slus-21215' in GameDB
[GameDB] Found 'slus-21215' in GameDB
[GameDB] Searching for patch with CRC 'B99A75DE'
[GameDB] No CRC-specific patch or default patch found
Vsync is OFF
Possible incorrect Q value used in COP2. If the game is broken, please report to http://github.com/pcsx2/pcsx2.
337aec  79420000 lq v0, 0x  0(t2)
337af0  00000000 nop
337af4  00000000 nop
337af8 *4A6D03BC vdiv Q, vf00w, vf13x
337afc  48A22800 qmtc2 v0, vf05
337b00  4BE12BAC vsub.xyzw vf14, vf05, vf01
337b04  4BCC73EA vmul.xyz vf15, vf14, vf12
337b08  4A8F7BC0 vaddx.y vf15, vf15, vf15x
337b0c  4A8F7BC2 vaddz.y vf15, vf15, vf15z
337b10 =4A807BDC vmulq.y vf15,vf15,Q
337b14  48227800 qmfc2 v0, vf15
337b18  7FA20000 sq v0, 0x  0(sp)
337b1c  44801800 mtc1 zero, f03
337b20  C7A00004 lwc1 f00, 0x  4(sp)
337b24  46030034 c.lt.s f00, f03
337b28  00000000 nop
337b2c  4501001B bc1t ->$0x00337B9C
337b30  7FA20010 sq v0, 0x  10(sp)
Possible incorrect Q value used in COP2. If the game is broken, please report to http://github.com/pcsx2/pcsx2.
337af0  00000000 nop
337af4  00000000 nop
337af8 *4A6D03BC vdiv Q, vf00w, vf13x
337afc  48A22800 qmtc2 v0, vf05
337b00  4BE12BAC vsub.xyzw vf14, vf05, vf01
337b04  4BCC73EA vmul.xyz vf15, vf14, vf12
337b08  4A8F7BC0 vaddx.y vf15, vf15, vf15x
337b0c  4A8F7BC2 vaddz.y vf15, vf15, vf15z
337b10 =4A807BDC vmulq.y vf15,vf15,Q
337b14  48227800 qmfc2 v0, vf15
337b18  7FA20000 sq v0, 0x  0(sp)
337b1c  44801800 mtc1 zero, f03
337b20  C7A00004 lwc1 f00, 0x  4(sp)
337b24  46030034 c.lt.s f00, f03
337b28  00000000 nop
337b2c  4501001B bc1t ->$0x00337B9C
337b30  7FA20010 sq v0, 0x  10(sp)

The emulator just closes. I'm using the latest nightly build, using the wxWidgets.
Reply




Users browsing this thread: 1 Guest(s)