[Bug Report] Conflict Desrt Storm
Hey guys, I was testing games with QT interface and realised this game was messing around with graphics.

I have been playing CDS 1&2 in the past without problem, so I tried with my already working install and a new one :
Wotking with 1.7.0 20200813 213500 https://youtu.be/0j9Jat6kKdo
Working less well 1.7.2 2791 https://youtu.be/DyLvoZiY99k
With my 1.7.0 it worked fine, in 1.7.2 the screen is flickering black in menu and during mission. Tried to copy settings (OGL and others) but no luck.

The wiki say :
Black box flicker
Status: Active
Type: Minor
Description: Upper left black box flickering
Workaround:No known fixes for HW, Press F9 to go into software mode. Alternatively: using PAL BIOS, set a PAL game in 50hz mode.
Turning to software (works but low res) or use 50Hz mode (50Hz by defaut, don't work even if I go to 60 and go back to 50) but it says it's minor and upper left when it's fullscreen for me so is it the same thing we're talking about?

Edit : After some tests, changing or not the settings didn't seems to afect this bug, the game works fine until 1.7.2125 but since 1.7.2126 it starts flickering like this, even without modifiying graphics or anything.

Edit 2 : Loading Screen background also disappear.

Sponsored links

Does adjusting the EE cycle rate make any difference?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Been in the Speedhacks tab and played with EE Cyclerate, Cycle Skipping, disabling speedhacks, no effect, tried the EE tab changing stuff, no effect neither.
Tried pcsx2-v1.7.2874 and still happening. I'd like to know, could it be possible for you to compile a recent release where you would have revert the changes of 1.7.2126 (Burnout black sky fix) so I could try it and see if it's this fix that causes some problems, for tests purpose? Or revert and make it a separate fix/hack if it's the problem?
So the game works OK in Software Mode?

I'm not hacking up a build to remove the burnout sky PR, there's already PR's waiting to fix related bugs, you can try them yourself to see if they resolve the issue:

Most likely: https://github.com/PCSX2/pcsx2/actions/runs/2404675765
Last resort: https://github.com/PCSX2/pcsx2/actions/runs/2066803591
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Yes the game runs fine in Software mode, but it's still a regression since it worked well before 1.7.2126.

Thanks for the links, but unfortunately I know absolutely nothing about GIThub and how to compile a thing Sad so I'll wait for a fix someday.
You don't need to compile it, the link I gave was to compiled build downloads, the only thing you will need is a (free) github account. Just be sure not to overwrite your normal build, since this isn't a mainline version.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Ok thanks for the info.
After downloading each of them I've got this :
Most likely : https://youtu.be/ISuvLSJ7DHA
Last resort : https://youtu.be/kxdiV4tfF7A
So most likely is a little worse, last resort is a little better since the full screen flickering is only in the upper left corner as mentioned in the wiki.
Cool, well "last resort" will likely be merging soon Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Tried on pcsx2-v1.7.3106 and there's still that black square flickering in the corner, just to let you know.

Users browsing this thread: 2 Guest(s)