[Bug Report] FinalFantasy10 [NTSU]
Hi Pcsx2 people! I've been playing my FFX disk off my laptop for about 6 days and ive finally got a MAJOR BUG. Here are things i work with.

Version of PCSX2: 0.9.8
Renderer: like the "How to post threads" post said, i tried both Direct3d9(Hardware) and (software). I cant try 3d10 cause it will not load up the video, only audio.

-I have everything almost to default like the EE/iop settings VUs settings.
-I turned off all hacks, still bugged.
-I would love it if anyone reading this answer me soon! You'll know why when you read the Bug description

Bug Description:
After acquiring the Air Ship for good now(right after defeating Lady Yunalesca), you are to go to the top of the air ship and fight Sin's weakness that is located on this arm. After sending it to 0 Hp, it activates a cut scene in which Cid says, "Hang on to something, im go'in in!" Right after finishing his little statement, it shows the Airship flying in the air. This is when PCSx2 just crashes and freezes. I am not able to continue after initiating this video. I CANT GET RIKKU's CELESTIAL STUFF AND I CANT CONTINUE TO KICK SIN'S ASS =,(

This happened on both hardware and software of Direct3d9

Suggestions anyone?

Sponsored links

could you please post the emulog.txt ?
FF10 is known to work fully under pcsx2
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Just tested it again. In the log report, it just says the same things as when you start it up, well i loaded a save state that i saved to test the bug if would work on other things.

Loading savestate from slot 1...
filename: C:\Users\Timmy\Documents\PCSX2\sstates\SLUS-20312 (BB3D833A).01.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2

There is nothing after this. When i try to exit out of PCSX2, it crashes and i have to force quit it.

The Video would now freeze, frame rate is stuck at a
random number, EE:0% GS:0 % UI;0%
try loading from memcard, and post the emulog.txt after the crash (if you still get one)
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Um, how would i do that? I have no clue.... (sorry, new to this)
Try making an iso out of the disc using imgburn and see if it still crashes could be just hitting a bad spot on the disc. and you have been solely relying on save states that could also be the issue as they are a lot less stable then using a memory card save.
Ok, ill try that. And I only do save states when I'm in sticky situations and for this instance to test the bug on other renderers. Other wise i just use the save sphere in the game. Its going to take awhile for it to turn into an ISO.
Well, just came back to check if it created an iso file. It is stuck at 78% and will not continue because it ran into an error. It keep on trying but it get error after error....i guess it really is an error with the disk.
Looks that way.
You could try making the iso in another drive or computer, see if you get better luck making it there then transferring it to your computer if successful.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
So we found that the issue is with the disc and not the emulator in this case so this one is solved then. Yeah try another drive and/or pc and see if that has better luck making it as some drives can get past errors while other have trouble like you are running into.

Users browsing this thread: 1 Guest(s)