Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] General Full Boot Issue - Non Game Specific
#1
Hi guys, my first post here and I'm reporting a bug I found.

I've been playing Shadow Hearts (USA) and found a bug if you boot iso (fast) vs (full).  I believe this is most likely a general bug which could affect more games than just Shadow Hearts.

Here's a picture for reference:
[Image: ftK3cjx.jpg]


The top is if you quickboot the game (skip the bios).  And the bottom is if you do a fullboot (I used the commandline --fullboot).  For some odd reason, there are graphical glitches only if you fullboot the game.  If you want to test out the exact scene yourself, I have uploaded the savestate here.   Once you load it, just go through the door.

Oh and I am using pcsx2-v1.5.0-dev-2241-g18ea36adc-windows-x86 build.
Reply

Sponsored links

#2
Set your EE Clamping mode to "Full" or enable Automatic Gamefixes.
Reply
#3
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Reply
#4
(03-01-2018, 06:12 AM)CK1 Wrote: Set your EE Clamping mode to "Full" or enable Automatic Gamefixes.

Hey thanks.  Though Automatic Gamefixes didn't do anything (I've had it on the whole time), setting EE Clamping mode to "Full" did the trick.  But any reason why a game would bug out simply for watching a bios screen vs not watching a bios screen?  Seems rather odd.  Also is there a downside to setting EE Clamping to "Full"?  Preferably I would just leave it on "Full" from now on as a master setting but I don't want it to negatively affect other games.
Reply
#5
What is your game serial?
Reply
#6
First it's specific to Shadow hearts. Second an easy explanation would be that when full booting, the automatic game fix was not applied for some reason.
[Image: newsig.jpg]
Reply
#7
(03-01-2018, 02:46 PM)Atomic83 Wrote: What is your game serial?

SLUS-20347

(03-01-2018, 04:47 PM)Bositman Wrote: First it's specific to Shadow hearts. Second an easy explanation would be that when full booting, the automatic game fix was not applied for some reason.

Okay that's a great logical conclusion.  I've tested it by putting it on EE Clamping Normal and disabling Automatic Gamefixes.  Then I ran the Fastboot.  And sure enough, you are right, the game reverted back to missing polygons.   So I can confirm, the problem isn't Fullboot, but rather the Automatic Gamefixes only applying it in Fastboot, and not on Fullboot.

So all we have to do now is hope someone fixes the Automatic Gamefixes bug in a future update.  Great!
Reply




Users browsing this thread: 1 Guest(s)