Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Jak 3 - Final boss defeated... ends with a black screen.
#1
# PCSX2 version: PCSX2 1.4.0
# CPU options: EE/IOP default, VUs default, speedhacks off, game fixes off.
# Plugins used: GSdx 20160105132032 (None custom installed)
# Video settings: Attached file on post.
# Description: 

In Jak 3 on the final boss, once the final blow is dealt it triggers an on-engine cutscene (like all cutscenes in the game). On my version, you'll hear the audio play from the scene but no video. Once you hear it stop, it doesn't continue onto the following cutscene and instead you can only hear the ambient sounds like weather. I looked up this scene on Youtube which is how I was able to find out what goes on.

What should I do to fix this? I asked some people on Discord but as you know, it's not like a forum where you can easily keep track of a discussion with others. They recommended a few things:
  • Turn off speedhacks, which I did have running. The game can only run smoothly with it on for me, but I will survive with it off if it means I can complete the game.
  • Restart from a memory save and not a save state. I almost exclusively play from save states as they are much more responsive and up-to-date than saving in the actual game's memory. Two of my three save states were at the final boss, and the remaining one was from about one-two hours prior in gameplay. Someone on Discord said that restarting from a save state at the end would keep the problem in, and only a clean load from a memory stick would reset it. Therefore, I restarted the mission from one of the two recent states to achieve this. Still no luck unfortunately.
  • Toggle between hardware and software mode. I did this because I found that it corrected many texture errors in the game, and I hoped it would resolve this one as well. It didn't.


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(03-07-2019, 10:50 AM)jesalvein Wrote: Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Alrighty. This run I did ended in the game crashing entirely and the program closing itself. This log reflects that occurrence which was started from the latest load state. If you'd like a log of an instance where it gives a black screen instead, I will run it to get that upon request.

Code:
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000
 
Host Machine Init:
            Operating System =  Microsoft Windows 10 Home (build 17763), 64-bit
            Physical RAM =  8063 MB
            CPU name      =  Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz
            Vendor/Model =  GenuineIntel (stepping 09)
            CPU speed    =  2.993 ghz (4 logical threads)
            x86PType      =  Standard OEM
            x86Flags      =  bfebfbff 7fbae3bf
            x86EFlags    =  28100000
 
x86 Features Detected:
            SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX
 
Reserving memory for recompilers...
 
Loading plugins...
            Binding   GS: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\gsdx32-avx.dll
Windows 10.0.17763
            Binding  PAD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\lilypad.dll
            Binding SPU2: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\spu2-x.dll
            Binding CDVD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\cdvdGigaherz.dll
            Binding  USB: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\USBnull.dll
            Binding   FW: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\FWnull.dll
            Binding DEV9: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.
 
(GameDB) 9693 games on record (loaded in 176ms)
HLE Notice: ELF does not have a path.
 
 
Initializing plugins...
            Init GS
Windows 10.0.17763
            Init PAD
            Init SPU2
            Init CDVD
            Init USB
            Init FW
            Init DEV9
Plugins initialized successfully.
 
Opening plugins...
            Opening GS
            Opening PAD
            Opening SPU2
Current Renderer: OpenGL (Hardware mode)
            Opening CDVD
isoFile open ok: C:\Users\████████\Desktop\PS2 Console\Games\PS2\Jak 3.iso
            Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (2205456 sectors)
            Opening USB
            Opening FW
            Opening DEV9
3.x GL context successfully created
OpenGL information. GPU: GeForce GTX 1060 6GB/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 391.35
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_separate_shader_objects is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
 
McdSlot 0 [File]: C:\Users\████████\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\████████\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
            Bios Found: USA v01.60(07/02/2002)  Console
            BIOS rom1 module not found, skipping...
            BIOS rom2 module not found, skipping...
            BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.63, ctm:392Mhz, cpuclk:294Mhz detected)
 
PlayStation 2 ======== Hard reset boot
 ROMGEN=2002-0207, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
 <20020207-164243,ROMconf,PS20160AC20020207.bin:11552>
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.
 
EE DECI2 Manager version 0.06 Feb  7 2002 16:41:20
  CPUID=2e20, BoardID=0, ROMGEN=2002-0207, 32M
 
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.30;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_973.30;1) Game CRC = 0x644CFD03, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_973.30;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
 
IOP Realtime Kernel Ver.0.9.1
Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SCUS_973.30;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SCUS_973.30;1
1 00100000 000290d0 ...
2 00129100 000096b8 ..
Loaded, cdrom0:¥SCUS_973.30;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
sce_fileio: unrecognized code ff
dkernel: boot:1 debug:0 mem:0 syms:0 dev:2 mod:1
Initializing CD drive
Disk type 20
Rebooting IOP...
Get Reboot Request From EE
ROM directory not found
 
PlayStation 2 ======== Update rebooting..
 
PlayStation 2 ======== Update reboot complete
cdvdman Init
 
IOP Realtime Kernel Ver. 2.2
Copyright 1999-2002 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
searchbyname: module name cdvd_ee_driver
searchbyname: return 21
stopmodule: module id 15 args 0 arg
stopmodule: return 21, result 1
unloadmodule: module id 15
unloadmodule: return 21
loadmodule: fname cdrom0:¥DRIVERS¥SIO2MAN.IRX;1 args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥DRIVERS¥PADMAN.IRX;1 args 0 arg
loadmodule: id 26, ret 0
loadmodule: fname cdrom0:¥DRIVERS¥LIBSD.IRX;1 args 0 arg
loadmodule: id 27, ret 0
loadmodule: fname cdrom0:¥DRIVERS¥MCMAN.IRX;1 args 0 arg
loadmodule: id 28, ret 2
loadmodule: fname cdrom0:¥DRIVERS¥MCSERV.IRX;1 args 0 arg
loadmodule: id 29, ret 2
loadmodule: fname cdrom0:¥DRIVERS¥989NSNM.IRX;1 args 0 arg
 
==========================================================
 989snd (c)2000-2003 Sony Computer Entertainment America
 by Buzz Burrowes                            v3.1.4
                    (built Sep  9 2004 at 12:50:39)
                                         (pre-release 24)
 
 NO MIDI VERSION! No MIDI, AME, or basic VAG sounds
              (banks and streams only)
 
 
 NO VAG STREAM VERSION!
 
 (build with sce library rev 2.7.2)
==========================================================
Thread Priorities:
                      Sound Tick = 9
                        Main RPC = 58
                    Loading RPC = 59
                      Streaming = 60, 61, 62, 63
==========================================================
 
loadmodule: id 30, ret 0
loadmodule: fname cdrom0:¥DRIVERS¥OVERLRD2.IRX;1 args 19 arg iso_cd
======== overlrd2.irx startup ========
  mem size:
total mem free:
  max mem free:
      used:
  start() addr: 0x0009c130
======== overlrd2.irx post-startup ========
  mem size:
total mem free:
  max mem free:
      used:
loadmodule: id 31, ret 0
Frame buffer size set to  512x512 (2048x2048)
Frame buffer size set to  640x512 (2560x2048)
 > Selected savestate slot 3
Loading savestate from slot 3...
            filename: C:\Users\████████\Documents\PCSX2\sstates\SCUS-97330 (644CFD03).03.p2s
EE/iR5900-32 Recompiler Reset
            Loading GS
            Loading PAD
            Loading SPU2
Closing plugins...
            Closing DEV9
            Closing FW
            Closing USB
            Closing CDVD
            Closing SPU2
            Closing PAD
            Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
Reply
#4
don't load from savestate, load from memcard.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(03-07-2019, 11:35 AM)jesalvein Wrote: don't load from savestate, load from memcard.

This resolved the issue. Thank you.
Reply




Users browsing this thread: 1 Guest(s)