Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Metal Gear Solid 2: Sons of Liberty [NTSC-U SLUS-20144]
#1
# PCSX2 version: PCSX2 1.5.0-20180213122600 - compiled on Feb 19 2018
# Emulation options: Default options + MTVU
# Plugins Used: GSdx (GCC 7.3.0 AVX/AVX) 1.1.0
# Description:

The game runs with near-perfect graphics from start to end, but there are three notable graphical imperfections:

  1. There’s a couple of transparent textures that are displayed completely opaque: The crystals from Otacon’s glasses (oddly enough, Emma’s glasses are rendered correctly), and the surface of the water in Shell 2. Both textures don’t work in software mode either.
  2. Some cutscenes are rendered at 10fps with motion-blur to give a dramatic slow-motion effect. In software mode this effect works perfectly, but in hardware mode the effect is only shown on a small portion at the left side of the screen (while the rest of the screen is rendered at 30fps). VIDEO: https://gfycat.com/JealousSmoothChupacabra
  3. Ocelot and Fatman use a special skin effect that shows veins popping out of the face or the arms. The effect works perfectly on software mode, but in hardware mode it needs the Bleeding Unit Accuracy to be set at Full or Ultra (which are extremely slow and only intended for debug).
               


Attached Files Thumbnail(s)
           

.xz   MGS2-Ocelot-Fatman-Skin-Effect.xz (Size: 2,03 MB / Downloads: 130)
.xz   MGS2_Slow-Motion.xz (Size: 2,88 MB / Downloads: 131)
.xz   MGS2_Otacon_Glasses.xz (Size: 2,89 MB / Downloads: 113)
Reply

Sponsored links

#2
Not 100% sure about the first two (The top-left corner issue exists in MGS3 as well - skipdraw could fix that at the expense of removing other effects)

Technically speaking, requiring a higher level of Blending Accuracy isn't exactly a bug - the tooltips (although they could be reworeded in the future) are meant to guide more "inexperienced users" and prevent them from slowing down the emulator too much Tongue.

There's a few games that require Full Blending Accuracy to emulate certain effects correctly, but Metal Gear Solid is very intensive when it comes to blending unfortunately. Wink

I assume all 3 scenarios were tested in OpenGL - try Ultra Blending Accuracy with those if you haven't already and report back. Could you also check to see if they exist in DX11?
Reply
#3
(02-26-2018, 01:10 AM)CK1 Wrote: Not sure about the first two, but requiring a higher level of Blending Accuracy isn't exactly a bug - the tooltips (although they could be reworeded in the future) are meant to guide more "inexperienced users" and prevent them from slowing down the emulator Tongue. There's a few games that require it to emulate certain effects correctly, but Metal Gear Solid is very intensive when it comes to blending unfortunately. Wink

I assume all 3 scenarios were tested in OpenGL? Could you also check to see if they exist in DX11?

Thanks for the quick reply Smile
Yes, everything was tested in OpenGL. Unfortunately I'm using Linux and I don't have a Windows license to test, but everyone seems to have the same issues on Windows using DX (all the YouTube gameplay videos I found show these problems).

Oh, and using the Ultra setting doesn't fix the transparent textures or the slow motion effect.
Reply
#4
Not sure about the glasses, they look the same in OGL HW w/ Ultra Blending and SW as well as DX11.

Edit: So I guess the only real issue is the slow motion effect - I don't see the issue in the GS Dump or the video. Can you post a GS dump from another scene with better contrast or the like that would make the effect more visible Smile
Reply
#5
You're comparing the glasses against the PS3 HD Collection(which is actually MGS2: Substance). But how does it compare to the original on PS2?
Reply
#6
Apparently they're somewhat opaque as well? I don't own the game so a real comparison would be better Tongue

Personally, I don't think there's anything wrong with the glasses. It looked the exact same in OGL HW/SW and DX11.

[Image: 608?cb=20131222063321]
Reply
#7
I checked the game and the issue with the glasses is as reported. I also checked older PCSX2/GSdx versions, but it seems it never worked.
Reply
#8
(02-26-2018, 01:29 AM)FlatOut Wrote: You're comparing the glasses against the PS3 HD Collection(which is actually MGS2: Substance). But how does it compare to the original on PS2?

I used a PS3 screenshot because I thought a PS2 screenshot would be too blurry to notice anything  Unsure


anyways, on a real ps2 it should look like this:

   


and in the emulator it looks like this (no matter what settings or renderer you use)

       
Reply
#9
(02-26-2018, 01:25 AM)CK1 Wrote: Not sure about the glasses, they look the same in OGL HW w/ Ultra Blending and SW as well as DX11.

Edit: So I guess the only real issue is the slow motion effect - I don't see the issue in the GS Dump or the video. Can you post a GS dump from another scene with better contrast or the like that would make the effect more visible Smile

Hmm... it's a bit complicated to show the effect with an image, but I'll try.

Here's another dump: https://www.dropbox.com/s/5222dszay9r1hu...gs.xz?dl=0

The effect is used in almost all the cutscenes.


Attached Files Thumbnail(s)
   
Reply
#10
EDIT: The slowmotion affects what seems to be a triangular section at the left side of the screen in hardware mode. Resolution and backend don't seem to affect it.
Reply




Users browsing this thread: 1 Guest(s)