[Bug Report] P2b support for SCPH-90001 BIOS [US]
After dumping the BIOS from my PS2, the non-beta PCSX2 v0.9.6 can load the BIOS rom0 file itself just fine, however when using the ps2dumper v2.0 .bat file to create the .p2b file, it does not show up in the BIOS list.

The files ps2dumper dumped were:

Also when loading the BIOS the old way, dropping all the files into the BIOS directory, running the emulator says the rom1 file was not found, but I can see it sitting in the BIOS directory. The other things it didn't find were rom2 and erom. Loading into the PS2 manager, that menu that shows up when no game is in the drive, crashes the program.

I did notice all eight charcters in between the [ and ] in the file name were different between each file.

I tried making them all the same. as the rom0 file. PCSX2 was able to load the rom1 file but still says it didn't find .rom2 and .erom . Since it loaded the rom1 file, I can load the PS2 manager fine.

I searched the forums for .p2b to see if anyone else had problems but the only thing that shows up was the post about ps2dumper v2.0 being out.

Other than that, the SCPH-90001 BIOS dating 2/20/2008 runs fine, date code is 8C on the PS2 Slim.

- Note 1 - My PS2 slim is not modded.
- Note 2 - I also tried the official beta 831 and same result.

Sponsored links

Yeah p2b never made it into the emulator. Do get the emulator to detect everything do this:
Right click on your p2b file and extract it using 7zip or Winrar.
Then,rename the SCPH-50004_EUR_Con_0170_20030227_v9.rom1 (whatever your filename is) to rom1.bin. That should do it Wink

Oh and rom2 with erom are missing in newer ps2 models so don't worry about them
[Image: newsig.jpg]
Ah, I see. Guess I'm playing catch up with the current info since I've haven't been following this emulator until recently. After renaming the files to all using the same name, it detects it now.
Yeah, exactly as bosit says. Moved to general Tongue

Users browsing this thread: 1 Guest(s)