Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] PCSX2 crashing to desktop on Savestate load attempt...
#1
I grabbed today's build from the Orphis build bot..
PCSX2 (v1.7.0-r622)(Dev)(vs2019)(Orphis)_Win32.7z

and tried to load a save state for Final Fantasy 12... but it failed crashing to desktop...
so I tried loading the memory-card save which worked fine.. then I did a new savestate...
overwriting the old one... tried immediately to load that savestate and it still crashed  to desktop on the following
Quote:Loading savestate from slot 0...
filename: foldername(removed for privacy)/SLUS-20963 (0779FBDB).00.p2s
EE/iR5900-32 Recompiler Reset
Loading SPU2
Loading USB


last working version or last version I tested was
PCSX2 (v1.7.0-r605)(Dev)(vs2019)(Orphis)_Win32.7z

I am running PCSX2 on Windows 10 v20H2 build 19042.630
and since I have Microsoft Visual Studios community 2019 installed
today there was and update to v16.8.2 I found and it did update the installed VC++ runtimes too...
to v14.28.29334 from v14.28.29325 for both 32bit and 64 bit ...
I wonder if that was the issue... or something else...
I have attached the emuLog.txt


Attached Files
.txt   emuLog.txt (Size: 65,67 KB / Downloads: 10)
(PC Specs)
CPU: AMD Ryzen 9 3900X 12-Core Processor
Motherboard: Asus PRIME X570-PRO (BIOS_r2802 [10/23/2020])
GPU: nVidia GTX 1070 Ti 8GB
GFX Drivers: Nvidia v457.30
OS: Windows 10 Pro (x64)
RAM: 32GB, 2x G.Skill 16GB DDR4
Reply

Sponsored links

#2
Same here. I tested several builds yesterday. to be specific they were 619 620 621 622 623 and minutes ago I tested the latest one 628.  exactly the same setting on each one of them. They all crashed when I load the savestate. and I tried changing settings like video driver audio driver also tried changing options in the drivers. It behaves still the same. I even changed the bios and languages with no luck. Changed the game. still the same. and finally. I go back directly to 604. and it works perfectly. no crash. so It's not our problem. It's the emulator itself. I hope they could spot and fix this issue later on. I'm on Win10 20H2 by the way.
Reply
#3
No problems here on v1.7.0-r631

1.Downloaded the latest beta
2.Copied my bios and memory cards
3.Run a game and load a memory card save
4.Create a save state and then load it,no problems
5.Restart pcsx2,run the game again and load the save state...no problems

Maybe it's a game specific problem but I tried 6 games and it was working fine
Reply
#4
I just tested v1.7.0-r631 32bit myself.
and the SaveState loaded fine.. the one I created with v1.7.0-r622
so it does not appear to be the SaveState at fault itself.

this apparently got fixed some how... not sure which commit did the fix but it works so all are happy again... lol Wink
so I guess this this can be closed or marked as fixed.
(PC Specs)
CPU: AMD Ryzen 9 3900X 12-Core Processor
Motherboard: Asus PRIME X570-PRO (BIOS_r2802 [10/23/2020])
GPU: nVidia GTX 1070 Ti 8GB
GFX Drivers: Nvidia v457.30
OS: Windows 10 Pro (x64)
RAM: 32GB, 2x G.Skill 16GB DDR4
Reply
#5
https://github.com/PCSX2/pcsx2/pull/3934
Should fix the issue when it's merged to master.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 10 Pro 64bit
Reply
#6
(Yesterday, 07:10 PM)lightningterror Wrote: https://github.com/PCSX2/pcsx2/pull/3934
Should fix the issue when it's merged to master.

ok TY for the info/update.
(PC Specs)
CPU: AMD Ryzen 9 3900X 12-Core Processor
Motherboard: Asus PRIME X570-PRO (BIOS_r2802 [10/23/2020])
GPU: nVidia GTX 1070 Ti 8GB
GFX Drivers: Nvidia v457.30
OS: Windows 10 Pro (x64)
RAM: 32GB, 2x G.Skill 16GB DDR4
Reply




Users browsing this thread: 1 Guest(s)