[Bug Report] Puzzle Quest: Challenge of the Warlords [NTSC-U]
# PCSX2 versions tested:  v1.7.4119 (nightly) - Windows 11, v1.7.2149 (nightly) - Windows 11, v1.7.4012 (nightly) - Steam Deck
# CPU options: all EE/IOP/VU defaults on all versions/platforms
# Plugins used: tested with OpenGL and software on all 3 platforms, Vulkan on the latest nightly and on Steam Deck, and DX11/12 on Windows
# Description: all graphics are flashing and corrupted, as if the game is attempting to render frames of different graphical layers in the wrong color space

This is noticeable immediately after the logo screens, when the game brings up the memory card message, but is extremely obvious on any screen which contains a significant amount of graphics (the title screen is a good example).  It's universal across all rendering modes (OpenGL, Vulkan, DirectX, software), and in both the NTSC-U and PAL versions of the game.  The game worked at one point, but the last report is from a decade ago, so any regression could be years old by now.

I haven't provided a GS dump since the issue happens on multiple platforms and requires no special setup or anything other than just starting the game.  I've attached a representative screenshot (it's from the PAL release but the NTSC screenshot is essentially the same), though the actual corruption flickers and flashes heavily.

EDIT: I'll spend a little time doing some bisecting with older versions to see if I can at least narrow down when the problem might have been introduced.

EDIT 2: The last version that worked correctly was 1.7.0-1550. The first version that was broken was 1.7.0-1553.

Attached Files Thumbnail(s)

Sponsored links

Users browsing this thread: 1 Guest(s)