Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Ratchet & Clank: Deadlocked
#1
I've noticed that on Ratchet Deadlocked, there is a weird bar on the sides of my screen and very glitchy shadows. Any help would be appreciated, thank you.

My specs: i5-8500, GTX 1060, 16GB of 2666mhz memory


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]

In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using, such as speed hacks or presets.
  • Your GSdx graphics settings (a picture of the settings dialog is preferred)
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Reply
#3
Specs: i5-8500, GTX 1060 6GB, 16GB DDR4 2666mhz, Windows 10

Version: v1.5.0-dev-2613-g48d9763d2

I'm running Ratchet & Clank: Deadlocked off of an ISO (Proof of ownership below)

(Screenshot of settings below)

I am running the Balanced preset for speedhacks



Code:
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.65;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
Input ELF format filename = cdrom0:¥SCUS_974.65;1
0 00800000 0019c03f ..........................
Loaded, cdrom0:¥SCUS_974.65;1
start address 0x800008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Elf entry point @ 0x00800008 about to get recompiled. Load patches first.
GSdx Lookup CRC:9BFBCD42
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init


IOP Realtime Kernel Ver. 2.2

    Copyright 1999-2002 (C) Sony Computer Entertainment Inc. 

Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15) 
iop heap service (99/11/03)

==========================================================
 989snd (c)2000-2003 Sony Computer Entertainment America
 by Buzz Burrowes                               v3.1.7
                        (built May 10 2005 at 19:36:08)

 NO MIDI VERSION! No MIDI, AME, or basic VAG sounds
                  (banks and streams only)

 (build with sce library rev 3.0.1)
==========================================================
    Thread Priorities:
                         Sound Tick = 9
                           Main RPC = 58
                        Loading RPC = 59
                          Streaming = 60, 61, 62, 63
==========================================================

Cheers!


Attached Files Thumbnail(s)
       
Reply
#4
You forget to enable 8bit textures,Auto flush and set round sprites to something....there are some more checkboxes in gamefixes too.
Some of those options will definetly affect the game in a negative way

Revert all of the settings to default and use OpenGL
Reply
#5
You can get rid of the colourful lines around the screen edges by setting the Half-Pixel Offset hack to "Special (Texture)" instead of "Normal (Vertex)". Some smaller lines may still appear in some situations.
(alternatively, you can disable the Half-Pixel Offset hack and use TC Offsets, this can result in better bloom alignment at the cost of worse scaling artifacts. I used X: 375 and Y: 350 (PAL version, 4x Native, widescreen patch enabled))

I don't know of any way to completely fix the shadows. They look slightly better on the OpenGL renderer with Blending Unit Accuracy on "Basic" (or higher).
Setting the VUs to superVU Recompiler improves the appearance of some shadows, but causes several other problems (stretched polygons, gaps in the world, etc.) and reduces performance.

(10-21-2018, 08:19 AM)vsub Wrote: You forget to enable 8bit textures,Auto flush and set round sprites to something.

Auto Flush hack doesn't seem to help Deadlocked/Gladiator - it results in additional shadow flickering and reduced performance (at high resolutions).
Round Sprite hack on "half" seems to have no effect, on "full" it causes vertical "seams" to appear across the screen. Bloom alignment is better than when half-pixel offset is not enabled, but worsened if it is enabled.
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | MSI GeForce GTX 1070 Ti Titanium 8GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#6
That's not the point I said that...enabling all in hope to fix things will always do more harm than good.
Some of them may actually fix something but other break something else
Reply
#7
Thanks guys, I got rid of the lines on the sides of the screen, but the shadows are still borked. I'll just deal with it though.
Reply




Users browsing this thread: 1 Guest(s)