Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Romancing SaGa [NTSC]
Version: 0.9.6 and beta 1888
CPU: all on in 0.9.6, all the old ones plus microVU on/off in beta
Graphics: GSdx 890 (SSE4.1) D3D9 Hardware/Software, ZeroGS 0.97.1 in 0.9.6; GSdx 1873 (SSE4.1) D3D9 Hardware/Software, ZeroGS 0.97.1 in 1888
Sound: P.E.Op.S. SPU2 1.9.0, threaded mode on
CD: Linuz ISO CDVD 0.9.0
Hacks: none

My machine:
Core2 Duo E8200
Geforce 8800GT
Windows XP 64bit

Bug: the game hangs in the after credits part of the ending.

More specifically, after a video fades out the game stays faded out. The displayed framerate is about 20-30, but nothing happens and the sound repeats. From watching the scene in a youtube video it seems the game should switch to another video. I already tried playing the last part of the game again and it still happens. For most of the things I tried I used savestates however.

Anyway, I haven't found any posts about this here, so it might just be some freak occurrence related to my system. However for me it happens every time.

Note: Romancing SaGa has problems with other sound plugins than peops. The video doesn't play at all with the other two SPU plugins. Also the video already hangs earlier if I don't use the threaded mode option for peops.

What should happen (the video before the crash starts at 6:55, the crash happens at 7:24):
What happens: see attachment

Edit: I also tried making a skip videos patch using the tutorial. It skips the intro of the game, but not the video that causes the crash.

Attached Files Thumbnail(s)

Sponsored links

Is it only this last video that doesn't work on SPU2-X or ZeroSPU2?
I'm asking because peops isn't exactly your most compatible choice either.
In fact I believe peops manages to break 50% of all FMV out there Tongue2
There are about 5 threads with people reporting this game hanging up after character selection or loading. The suggested fix is using peops.
Small update: I can load a savestate made during the video (using peops because it doesn't start with the other two sound plugins) with ZeroSPU2. The video plays normally, but without sound, and the same bug occurs. When loading a savestate during the video using peops or SPU2-X the game hangs by the way.
(10-06-2009, 01:32 PM)Galefury Wrote: There are about 5 threads with people reporting this game hanging up after character selection or loading. The suggested fix is using peops.

Old threads maybe? I can play the game just fine with spu2-x.

The savestate you made with peops is broken. Loading it with any other plugin doesn't make it less broken Wink
Oh! I misread the game title (whops Tongue2 ).
My game is "unlimited saga", and only that works fine. Sorry for that.

So the real issue to fix is spu2 dma transfers again.
The devs know of that problem and I tried to (hack)fix it several times already.
There seems to be no way around rewriting the whole dma code, maybe even all of SIF.
In short: The real fix for this might take a while yet..
According to the compatibility thread, the NTSC-J release works fine. Considering this report is from 0.9.8, I'm sure the NTSC release would work fine as well. Retest whenever somebody gets a chance Smile

Users browsing this thread: 1 Guest(s)