[Bug Report] Sacred Blaze [NTSC-J]
# Pcsx2 version: 1.0.0395, beta Playgrounds, 0.9.6, recently official betas
# Cpu eerec on, vurec0 and vurec1 on, MTGS on, Frame Limit
# Speedhacks none at all. EE default cycle rate
# Advanced default (checked all options 1by1 but no change)
# Plugins used: Gsdx 0.1.4 to 0.1.15 / zerogs 0.9.7
spu2ghz/ zerospu/ SPU2-X and newest beta plugin pack

# Description: The game stops at some chat scenes.
In this screenshot, he says there's a portrait in this locket pendant.
A 'snap' opening effect sound plays. (no visible changes in the screen)
Then nothing happens and won't accept any buttons I push.
The characters have blinked so it's not freeze.
Just next event wont be executed and can not proceed the game any further.

Same thing happened with old PG(like r479) at a conversation scene in early chapter but it's fixed in the merged official betas.
I think there may be more chatting scenes that the game stops at.

Muting sound(ghz, zero, X) and gsdx software rendering didn't help.
Though there's a few more rendering bugs because of gsdx,
the game playing itself is perfect and fullspeed so far except this bug.

Attached Files Thumbnail(s)

Sponsored links

Please try different options in the advanced configuration.
Especially try increasing FPU and VU clamping.
I tried these on beta976 but couldn't get any improvement.
EE clamp none - VU clamp none
EE clamp none - VU clamp normal
EE clamp none - VU clamp extra
EE clamp full - VU clamp extra+preserve sign
and FtZ DaZ on off.
round mode changes
The game works pretty well with normal clamping in PCSX2 1.1.0.r5406 but there is bug with post-processing effect with gsdx (probably known as it's mentioned in wiki). I tried to play with gsdx HW hacks but with no effect. Is there any way to fix it?

The first and third images are HW-accelerated game and the second is from software renderer.

Attached Files Thumbnail(s)
try using hw hack skipdraw
I've tried skipdraw with values 10 and 100 and it seems have no effect at all.

Ohh.. random meddling with presets got the problem fixed. It was FPU Negative Div hack.
Those NTSC-J games just love it. ^_^

Probably this will be better in GameIndex.dbf:
Serial = SLPS-25917
Name   = Sacred Blaze
Region = NTSC-J
eeClampMode = 1
vuClampMode = 1
FpuNegDivHack = 1
Are you saying GSdx hardware rendering glitches get fixed by setting the FPU div hack?
I find that very hard to believe Tongue2
I am not saying anything as I am not proficient enough to judge. The fix is most probably reproducible and all I can say that I can see black line in the middle and half screen corruption (looks like a shader bug) without the hack and it works normal with it. Only if you have knowledge in the actual code you can say more about what code is relevant, gsdx's one or some other.
(09-09-2012, 09:32 PM)rama Wrote: Are you saying GSdx hardware rendering glitches get fixed by setting the FPU div hack?
I find that very hard to believe Tongue2

the Div hack does resolve graphical issuesin gundamn, so we can't discount that it has an effect (positively) in this case.
Well, this is weird enough to take a closer look then.

Users browsing this thread: 1 Guest(s)