Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Silent Hill 3 and Silent Hill 2 Graphical wall Bug [NTSC-U]
I have tested Silent Hill 2 and Silent Hill 3 in the following builds

# #PCSX2 version:
0.9.6 (Stable Release)

# #CPU options: Have tested with the defaults (Microvcompiler, Clamping mode Normal, Flush to Zero and Denormals turned on ETC) Also attempted unchecking Flush to Zero on EE and Vus and tested Legacy Supercompiler in EE and Vus. All combinations in 0.9.7 have resulted in the effects below

# #Plugins Used: GSDX 3693 0.1.16 SSSE4 and SSE3 with special silent hill fix (Hardware and Software)
GSDX 3693 0.1.14 SSSE3 (Hardware and Software)
ZeroGS 0.97.1 3878

No Hacks or Game fixes in all the above

# #Description of the bug and of how to replicate it

In 3878 and 3113 Regardless of plugin or configuration settings used (Tested with Controller, Keyboard and in both available Controller plugins, Tested with Multiple versions of GSDX and ZeroGS with both the hardware and software modes on each version (ZeroGS however causes the game to crash upon loading a save) when attempting to turn the character around by going to the left, right or backwards, the game acts as if there is a wall blocking them even when there is none there, forcing the character to go in a different direction. Sometimes by pressing directions randomly they will go back, but only diagonally, as if something is pressing them to the edge. After attempting to go backward going forward often becomes an ordeal as well.

I have found that using 0.9.6 fixes this issue. However I am concerned about compatibility on this build and the GSDX plugins which work on it do not allow AA hacks, and squeeze the game into a letter boxed window no matter what settings I pick.

This happens in both Silent Hill 2 and 3, but the first occurrence in Silent Hill 2 happens in the Graveyard where you meet Angela and the First occurrence in Silent Hill 3 can be found as soon as you launch a new game and gain control of Heather you may have to run around in circles a bit to notice it. In other words some areas do not seem to be affected by it in Silent Hill 2, but most are. Only in 0.9.7 build though, 0.9.6 results in no character control problems at all. I have tried the older GSDX plug in in a both 0.9.7 builds and confirm the bug still happens, I also turned EE and VU flush to zero off on 0.9.7 and tested the legacy superrecompiler on EE and VU which resulted in no change. Thus it is not a plug in or config issue that can be fixed with basic changes. Naturally, if there is a fix for this I would love to test it, if not I hope to hear good news on future builds as I do like the new features available in 0.9.7 and would like to not do without them for these wonderful games.

Incase it matters he are my system specs for Reference (though its irrelevant since another build works could maybe be a conflict with ATI or intel drivers that 0.9.6 didn't have?)

Windows 7 64 bit Pro
Intel Core i7 870 2.93ghz native clock
ATI Radeon HD 5870 1GB Catalyst 10.5 with Application controlled settings

Sponsored links

Please edit your post following this format:

I have Silent Hill 3 somewhere, guess I can check it out if it happens right as you start.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
(12-10-2010, 11:39 AM)Shadow Lady Wrote: Please edit your post following this format:

I have Silent Hill 3 somewhere, guess I can check it out if it happens right as you start.

This would be most appreciated, hopefully its not unique to my setup >_> and if anyone wants to test it on Silent Hill 2 all they need to do is skip the cutscenes and go through 2 or three screens from the start of the game, then skip another cutscene and try wandering around the graveyard they end up in. If you run around enough you will notice James won't go in certain directions with any amount of force, same as least if its not my issue lol
Ok, I got the problem too and it only happens in the 2d control type, but anyways this was already solved in the SVN and should be fine in the next release so moving this out of bug reports.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
That's good news ^^ I look forward to the next release then.

Users browsing this thread: 1 Guest(s)