Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Soul Calibur 3 [PAL]
# PCSX2 version: 1.5.0-dev-1875-g23d081a

# CPU options: EE/IOP defaults, VUs defaults

#Speedhacks: MTVU on 

#Tested with software and hardware modes of DX11 and OGL graphics plugins.

# Plugins used:
[Image: t1C16Qy.png]
# Description: Started a fight against Will-o-wisp in Tales of the Sword mode and all the graphics went odd, followed by going completely black. My character also seemed to be teleported out of the ring a couple of times. See video for further detail:

Shadows of previous rendered frames sometimes appear over the game when reloading a state (DX11 hardware. Not tested with other graphics modes).

#Link to savestate:

Sponsored links

Did you try it without the MTVU speedhack?
(02-03-2017, 01:19 AM)FlatOut Wrote: Did you try it without the MTVU speedhack?

Just checked. Still happens.
Do you have System -> "Automatic Gamefixes" enabled?
(02-03-2017, 01:35 AM)FlatOut Wrote: Do you have System -> "Automatic Gamefixes" enabled?

Another graphical glitch I've encountered is that, on some stages, the lighting will be much darker than normal. Either this is a problem with new PCSX2 releases or perhaps it is a problem specific to PAL. I changed from playing NTSC Soul Calibur at the same time as I updated to the newest version. I last updated around the time mipmapping was implemented, I think.

I have never noticed this as being a problem with the NTSC version.

It is not a problem in OGL mode, just in Direct3D11, but OGL runs Soul Calibur 3 much slower than D3D11 so I tend to stick with D3D.
Just happened again on another stage in another scenario. I don't have a savestate this time but here's a video:

Happens with all renderers again.
Do you have the issue in old build?
I've just tried it with the last stable (1.4.0) and it happens there as well.
I also tried with the NTSC version and the same thing happens there.

I've just tested to see if the decreased lighting on some stages is exclusive to the PAL version and it turns out that it is. That's only happening in PAL. It isn't a big issue, but it's a little annoying. Only happens in D3D but OGL is much slower for Soul Calibur.
I've tried it again with a newer version (latest version v1.5.0-dev-2104-g49840bb) and it's still an issue.

Users browsing this thread: 1 Guest(s)