[Bug Report] Star Ocean 3 [NTSC]
#PCSX2 version: 0.9.7 build r3878
#CPU options: (I can't find "CPU" under Config) Everything default except Game Hack enabled - option #1 checked to allow Tri-Ace games to boot (otherwise the game won't start at all)
#Plugins Used: GDdx, SPU2-X, LilyPad (all r3878, from that august 2010 update download)
#Memory card save error. Okay guys before you flame me for an incomplete bug report please let me explain.

I was using a save point (Sphere corp, floor 211) and as usual I saved my game in slot 1 - btw I save on memcard infrequently, I always use savestates; this is just a "just in case" thing. After saving I noticed I didn't get a save confirmation this time. I always return to save again to check the time on the save so I did that, and to my surprise slot 1 was empty (I never save in other slots). I saved again and this time it worked.

I thought nothing of this little irregularity until a short while later when I earned a battle trophy, then when I tried to save it the game complained that there was no battle trophy save! So I booted the emulator and browsed the memcard: yep, only the SO3 save file was there, the battle trophy save was missing. I had a few other game saves on that memcard and they appeared untouched.

Tried played a few different games and saved/loaded in them. Every time it worked fine; browsing the memcard also shows the saves. I'd also like to note that I've been using memcard saves for around 25+ games for the past year and have had no issues either on this version of the emulator or on the previous (0.9.6 official) version.

What's odd to me is that Star Ocean 3 has separate saves for game saves and battle trophies. If it was just a random save glitch I wouldn't expect the battle trophies save to get erased as well. They're separate. You can even download them separately from GameFAQs.

So I'm not certain whether this is a Star Ocean 3 random bug, or a general memcard bug. Before I posted this I searched the forum for both "memcard" and "star ocean" and got no relevant hits.

- after saving the game no confirmation appears (SO3 will always confirm success)
- checking the save right afterwards shows the save slot to have been mysteriously deleted
- saving again immediately (even in the same slot) seems to work, confirmed by browsing memcard after booting the emu; however, the separate battle trophies save is also missing

Sorry it's not much of a bug report but where else should I note this? And if I just kept quiet that won't help anyone. So I figured I ought to post this here so later if someone else comes across this they could verify that I got hit by this too. Or they could let me know this is a bug that occurs under specific conditions, or that it was a user error and I shouldn't have done X but Y instead. I dunno.

Well, there's nothing to do really except be more paranoid in making memcard backups. I do already use multiple savestates when playing games but I've always left memcards alone. The loss of the SO3 battle trophies isn't catastrophic, I simply downloaded a replacement from GameFAQs and imported it to my memcard via myMC. But you don't always want to simply download somebody elses "zomg 100% complete" save. Fortunately for me I never really cared about meaningless achievements but with what happened I thought it'd be best to post so that other people can be more careful with their memcard saves.
Visit the official PCSX2 wiki: http://wiki.pcsx2.net/

Sponsored links

Using savestates a lot and memcards at same time is not perfect, that's why using both systems is recommended (save to memcards as you would regulary on your PS2 and use savestates whenever you like).

Currently there's some problems with memcard detection after using savestates and needs improving but as you saw it it's not a regular thing and probably the problem you got.

Not a Star Ocean bug, moved out.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Hmm, yeah? Thanks. I'm always careful not to state at the same time or immediately before/after using a memcard save. Thing is, I've been doing this all this while with no problems. Strange. I guess there really is no fix except to make more backups. I was lucky SO3 battle trophies aren't vital but it could be a real issue in other games.
Visit the official PCSX2 wiki: http://wiki.pcsx2.net/

Users browsing this thread: 1 Guest(s)