[Bug report] Ico [NTSC]
Sorry if there's already a thread regarding this, but I haven't seen one after searching the forum.

Tried v0.9.5, v0.9.6 and the latest r1888 beta version too. All the three have a severe graphical glitch, where the scenes at far distance are covered by a thin foggy thingy, somewhat like a curtain (see pics 1, 2 and 3).

Meanwhile, the issue with r1888 is even more than that, with an additional double-image problem occurring all the time (see pic 4).

As you can see from the 2nd screenshot and 3rd one, the "fog" moves as you move, with its scale extending or shrinking btw.


Hardwares I use:

OS: Windows Vista Ultimate 64-bit (Simplified Chinese edition, with ICH10R AHCI enabled)
CPU: Quad Core Q9400 @ 2.66GHz
GPU: GeForce GTX 285


Gsdx SSE4.1 for each of them; DX10 (hardware) is used (Speaking of this, Dx9.0c can't be used, since it'll crash).
I've tried switching on and off almost every lil thing (e.g. Native, Tex filtering, aspect ration etc.) too.

Dual core mode and Hyper Threading mode are enabled.

Tried adjusting speed hacks and advanced settings like hell as well. Nothing worked.


Different bios (USA, EU, JPN) have been tried as well.
And btw, the version of the game I use is traditional chinese version, hmm... if that matters.

Attached Files Thumbnail(s)

Sponsored links

How about software renderer in GSdx?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
I guess the formation of my previous post is wrong. So here I'm writing this again.

# Pcsx2 version: v0.9.5, v0.9.6, r1888
# Cpu eerec on, vurec0 and vurec1 on, MTGS on
# Plugins used: Gsdx (hardware dx10) for all of them
# Description: Strange "foggy" thingy that moves as the character moves (when you move camera, it also does), with the fog's scale extending or shrinking. r1888 even has a more serious problem (double-image). Screenshots can be viewed in the 1st post.

And yes, tried with all hacks off, problem still existing.

Machine specs:

#OS: Windows Vista Ultimate 64-bit (Simplified Chinese edition, with #ICH10R AHCI enabled)
#CPU: Quad Core Q9400 @ 2.66GHz
#GPU: GeForce GTX 285
(10-08-2009, 04:02 PM)Shadow Lady Wrote: How about software renderer in GSdx?
Oh, thanks for reminding. ^^ I've just tried it and yea the problem's gone.
So it's hardware-exclusive...
Then it is a GSdx problem, sorry but this section is not for those bugs and youre better off posting it in the GSdx thread... as aditional info ICO seems to have a CRC based fix so you probably dont have a game version that has the CRC fix and in that case say your CRC in the GSdx and maybe it'll be added later or iff you know how you can add your crc and compile it yourself.

Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64

Users browsing this thread: 1 Guest(s)