Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug report] Prince of Persia: Warrior Within [PAL]
#1
# PCSX2 version: 1.5.0-dev-2334
# Emulation options: Defaults
# Plugins used: GSdx OpenGL Hardware and Software
# Description: Alright, so there are multiple different issues with this game none of which happen in Sands of Time or Two Thrones:
1) Bottom half of 3D rendering field is screwed in HW mode unless you enable Progressive Scan. It's either black or tinted green.
2) Issues with sound playback in FMVs. When a movie starts, sound stutters, then skips, then goes back to normal. This is especially problematic with the map screen and viewing illustrations in Extras menu (which actually use video files).
3) The last one is pretty weird, the camera in main menu is supposed to move around as seen here: https://www.youtube.com/watch?v=tT9zKy3Qf7s But in PCSX2, it remains static.
Reply

Sponsored links

#2
Can you post some images to go along with the problems you're describing?

Also, what SPU2-X settings are you using?
Reply
#3
(03-30-2018, 09:55 PM)CK1 Wrote: Can you post some images to go along with the problems you're describing?

Also, what SPU2-X settings are you using?

Here are screenshots of how main menu appears with and without Progressive Scan plus in-game screenshot without Progressive Scan.

I'm using default SPU2-X settings (XAudio, TimeStretch, etc).


Attached Files Thumbnail(s)
           
Reply
#4
OK, can you check 1.4.0 stable and see if the issue with Progressive Scan is still there? Can you also check the DX11 renderer with 1.5.0/1.4.0 and tell my if the issue is there as well?
Reply
#5
(03-30-2018, 10:35 PM)CK1 Wrote: OK, can you check 1.4.0 stable and see if the issue with Progressive Scan is still there? Can you also check the DX11 renderer with 1.5.0/1.4.0 and tell my if the issue is there as well?

Tried DX11 in dev build, it's same as OGL.
Tried 1.4.0 build, OGL is same as in dev build, DX11 is broken entirely - 3D field is not rendered, that's how it used to be for a while until it was fixed in OGL.
Reply




Users browsing this thread: 1 Guest(s)